Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After changing a few lines in xorg.conf, I can no longer boot Ubuntu (I assume it breaks when trying to load up X), so I need a way to boot into a single-user mode. However, there seems to be zero guides on the Internet how to do it, because they all assume I can actually edit files on my computer, and I obviously can't.

So how do I load Ubuntu in single-user mode?

When I turned off splash, I figured out the problem: whenever Ubuntu can't load X server due to some error, it switches to tty1 and waits for the prompt, but doesn't turn off the splash.

share|improve this question
    
Could you provide a little more info about your update? Why does not turning off splash when Ubuntu can't load X server lead to problems? –  irrational John May 7 '12 at 11:49
1  
@irrationalJohn Because splash screen doesn't disappear so you can't see the console and might not even realize it's there ready for the login. –  Alexei Averchenko May 7 '12 at 13:50

3 Answers 3

up vote 29 down vote accepted

To boot into single user mode you edit the boot instructions for the GRUB menu entry you wish to boot and add the kernel parameter/option single. Brief instructions for how to do this are below.

  1. Select (highlight) the GRUB boot menu entry you wish to use.
  2. Press e to edit the GRUB boot commands for the selected boot menu entry.
  3. Look near the bottom of the list of commands for lines similar to

    linux /boot/vmlinuz-3.2.0-24-generic root=UUID=bc6f8146-1523-46a6-8b\
    6a-64b819ccf2b7 ro quiet splash
    initrd /boot/initrd.img-3.2.0-24-generic

  4. Change the middle line in (3) by adding the kernel boot parameter single to the end of the line (i.e. after ro quiet splash).

    For this example you would change
    6a-64b819ccf2b7 ro quiet splash
    to
    6a-64b819ccf2b7 ro quiet splash single

  5. Press either Ctrl+X or F10 to boot using these kernel options.

Note: These changes are not persistent. Any change to the kernel boot options made this way will only affect the next boot and only if you start that boot by pressing either Ctrl+X or F10 while still in GRUB edit mode.

share|improve this answer
    
Thanks a bunch, this helped me diagnose the problem! –  Alexei Averchenko May 7 '12 at 5:41
    
how about changing ro to rw so the file system gets mounted writable, so you can make your changes stick? –  sjas Aug 14 at 12:11

Good question! When booting the machine hold down the left shift key. For more info follow this:

https://wiki.ubuntu.com/RecoveryMode

share|improve this answer
    
Recovery mode refuses to load just like the usual mode. –  Alexei Averchenko May 7 '12 at 4:01

Not sure why the instruction is not permanent.

To make it permanent edit "/etc/default/grub"

pico /etc/default/grub

Make the same changes...

update-grub

I changed the line "ro quiet splash "

to "ro text single " and i start GUI with

startx
share|improve this answer
1  
It's not supposed to be permanent, it's damage control. –  Alexei Averchenko Nov 12 '13 at 11:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.