Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just upgraded from 10.10 to 12.04. A picture says a thousand words in this case. Here's a G+ post with a screenshot of my menu bar:

enter image description here

I've tried messing with the clock settings---specifying a time zone, un-checking & re-checking "show a clock in the menu bar", and asking that "weekday" and "date and month" be displayed with the time. Nothing seems to work. Any ideas how I can get the actual clock to display instead of the word "Time"? Thanks.

Requested system information:

jason@pinot:~$ gsettings get com.canonical.indicator.datetime custom-time-format
'%l:%M %p'
share|improve this question
please open aTerminal window, run gsettings get com.canonical.indicator.datetime custom-time-format and post its output. – Florian Diesch May 7 '12 at 1:28
Thanks for the suggestion. Just posted. – jrennie May 7 '12 at 2:09
up vote 6 down vote accepted

Launchpad bug #863341 has the solution to my issue:

$ sudo dpkg-reconfigure --frontend noninteractive tzdata

After I ran the above command, "Time" disappeared and the current time is now displayed in my menu bar. The bug also notes that this question has previously been discussed on askubuntu.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.