Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Basically, when I try and drag a song from my library to any one of my iPods (Classic (2.0.4 Mac), Touch (3.1.2. (7D11)) and Shuffle), nothing happens. It would appear that everything went ok, but when I go to the iPod's library, the song is not there. When trying to transfer the file, there is no error etc. to indicate what went wrong, and so I can't file a bug report on Launchpad etc.

Does anyone know what could be wrong?

EDIT: I forgot to add that I'm running a 64-bit install of Ubuntu 12.04LTS and that Amarok and gtkpod don't even recognise that any devices are plugged in. Thanks.

share|improve this question

closed as off-topic by Olli, Eric Carvalho, mikewhatever, Maythux, Amith KK Feb 18 '14 at 5:08

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Olli, Eric Carvalho, mikewhatever, Maythux, Amith KK
If this question can be reworded to fit the rules in the help center, please edit the question.

See this – beeju May 7 '12 at 1:02
@beeju, I have had a read through that previously, and I should have mentioned that I have already tried to use gtkpod and Amarok, which simply don't recognise the devices. I should also have mentioned that I'm running a 64-bit install of 12.04LTS. Sorry! – Jonathan Jones May 7 '12 at 11:53
I've same settings: $ uname -a Linux ElAtuel 3.2.0-25-generic #40-Ubuntu SMP Wed May 23 20:30:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux and same problem. – Ale Jun 29 '12 at 0:49
I tried installing gtkpod and ubuntu-restricted-extra nothing happened until I disabled the portable player plugins. Not sure what happend. I'll keep looking. Try disabling the plugins. – Ale Jul 5 '12 at 21:30

I can confirm that on 10.10 (32bit) the above fix works:

apt-get install gtkpod ubuntu-restricted-extras

Simply restart Rhythmbox and if the iPod doesn't auto recognize do the following:

[Music] → Scan Removable Media

and give it a few moments: (mine took 3 minutes to index, not sure what it was doing but took a few moments before it showed up)

Also ensure in the plugins that iPod is ON:

[Edit] → Plugins → Portable Players - iPod

I have a 6th Gen iPod classic 160GB.


You can also after you verify all of the above, do the following if the iPod is still not showing up...

Simply click [Music][Import Folder] → (On the left(in Places) of the new window you should see the connected iPod listed) Click the iPod, and CLOSE that window with [Cancel] *(hopefully you'll see the iPod listed in Devices now. :)

share|improve this answer
i have 12.04 at home (and confirmed this works there as well) – knope Oct 2 '12 at 16:05
Worked perfectly on 12.04 64bits! Thank you! – Francisco Presencia Jan 18 '13 at 7:23
Followed all these steps, but my ipod is still saying: "No music - You can sync music from iTunes." I have a 6th gen 8gb nano touch, and I'm running 12.04 – mdegges Feb 13 '14 at 23:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.