Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 10.04 installed on my laptop, with an ATI Mobility Radeon HD 3670. I would like to connect this to an external monitor and use multiple desktops, as opposed to a single extended desktop.

I have tried selecting "Display Manager -> Multi Display -> Single display desktop (Multi-desktop)" and rebooting. This does give me two desktops, but after I move my mouse from the first desktop to the second desktop I can not move it back, and there appears to be no way to switch between the desktops.

I have read that people suggest enabling "Display Options -> Xinerama" but as far as I understand this would not dynamically adjust the set up depending on whether I have an external desktop connected.

I need a solution that will let me easily transition between one and two desktops as I often transition between using one and two screens (laptop + external monitor).

The "Single display desktop (Multi-desktop)" setting would be appropriate, if only I could figure out how to switch between these desktops.

Some people have mentioned using open source graphics drivers instead - is this likely to solve the problem? I assumed that the propriety drivers would be better.

share|improve this question
    
I originally had the fglrx driver from the Ubuntu repositories, however this was a few versions behind the drivers on the AMD site, so I have manually installed Catalyst 12.4 following these instructions: help.ubuntu.com/community/BinaryDriverHowto/ATI. While I did get the drivers to work, I still have the issue of not being able to move my mouse between desktops when "Single display desktop (Multi-desktop)" is enabled. –  Daniel May 6 '12 at 23:58
    
Just to clarify, I am able to move my mouse cursor from the first desktop to the second, but once it's on the second desktop I can not move it back to the first. Occasionally dialogue windows will open on the first screen instead of the second, and I am able to enter keyboard input (e.g. the admin password box will show on the first desktop, but I am still able to enter my password and press enter). –  Daniel May 7 '12 at 0:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.