Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried to follow the best answer on this question Is there an Ubuntu theme available to make it look like Windows 7? but when I enter this code ./win7-setup.sh I get this error:

enter image description here

And I have tried to run this command in "GNOME", "GNOME Classic" and "GNOME Classic(No effects)"

I'm running Ubuntu 12.04 64bit.

EDIT:
I have installed gdm and tried using gnome-classic with gdm and got the same error.

share|improve this question
    
it doesent work on gtk3 sadly! –  user67686 Jun 1 '12 at 12:13
add comment

3 Answers

up vote 1 down vote accepted

Try this:

Start up your machine. When you get to the login window press ctrl+alt+f1. This will drop you into a commandline shell where you have to log in as well (the password will show no input on the screen, it's supposed to be like that for security reasons)

Now please type the following commands:

sudo killall lightdm
sudo stop lightdm

To make sure the running display manager has stopped.

Now activate the gnome-display-manager by typing

sudo gdm

After a few seconds you should see a new login screen please make sure a gnome-classic session is selected and log in to your system.

Now try the installation script again (make sure you run it with superuser privileges.

share|improve this answer
    
I've tried that, but i got the same error. tried both gnome-classic and gnome-classic(no effects) –  Jeggy May 7 '12 at 6:56
1  
It probably does that, because the window theme is build on gtk 2.x but the new gnome versions use gtk3.x . To just bypass the check and see if it works, I commented out the portions in the script where it checks for the desktop session. You can downloaded from here: ubuntuone.com/11BZl2tHFvPjffQRo7jFEN –  Daniel May 7 '12 at 7:24
add comment

This seems to be a security bug. Actually security policies for GDM is basically stored in /etc/dbus-1/system.d . So, in order to own the name org.gnome.DisplayManager there has to be a file in

/etc/dbus-1/system.d // by default called gdm.conf

that has:

<allow own="org.gnome.DisplayManager"/>

in it (among other things). Just try to check it if the above tweak works for you. Then just follow the procedures normally as told you in answer 1.

share|improve this answer
add comment

Check Maverickz' answer here: http://www.zxeen.com/2011/03/how-to-download-install-windows-7-theme-in-ubuntu-linux/

The cause of the problem is that the desktop session is not being reported as Gnome. The simple fix is to edit the win7-setup.sh file and search for the following line:

[ $DESKTOP_SESSION = "gnome" ]

and change it to:

[ $DESKTOP_SESSION = "gnome-classic" ]

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.