Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was using Windows 7 for months and never had any problem with overheating, then I decided to try Ubuntu and I just loved it and decided to migrate.

However, the computer keeps shutting down for overheating problems, As of now the temperature is 75C, And I'm doing nothing special.

I'm running Ubuntu 12.04 LTS AMD64 and these are system specs:

2nd Generation Core i3
8GB RAM
64GB SSD
Geforce 540M
share|improve this question
    
what kind of graphic card do you have? –  Kempe May 6 '12 at 19:27
add comment

6 Answers 6

TRry installling the latest graphic card drivers from the site of ATI. as there are a lot of issues coming up for the drivers and heating problem with ubuntu

share|improve this answer
add comment

Check the system monitor (or better top command) for cpu devouring processes. Its more likely those processes to overheat you laptop. Also consider buying laptop coolers

share|improve this answer
add comment

I've been reading about a lot of issues with CPU overheating in Ubuntu, particularly with Sandybridge processors, with the blame being placed on all sorts from flash to internet explorer(?!). From my own research and experimenting with different distros, it seems the issue is with the linux kernel. 12.04 was supposed to solve these issues, but the 3.2 kernel in this distro still doesn't seem to play well with sandybrige; I'm using 12.04 with a quad core i7, and while my overheating issues are not as extreme as some I've read about, it does non-the-less overheat, and harnesses nowhere near the full power of my processor. Kernel 3.4 was supposed to bring, amongst other things, improved sandybridge performance; I've installed the Ubuntu specific 3.4 kernel, and there is some improvement, but put into the context of what my processor is capable of (and fully achieves in Win7) it's still just not good enough. Such a shame, I love Linux, and Ubuntu, but if it can't harness new tech, what's the point?

share|improve this answer
add comment

Try to install the new beta version of Nvidia 319.12 with bumblebee.

sudo apt-get remove bumblebee-nvidia nvidia-current nvidia-settings

sudo apt-get install bumblebee-nvidia nvidia-319 nvidia-settings-319

Link http://orkultus.wordpress.com/2013/04/20/how-to-nvidia-319-12-drivers-in-ubuntu-based-systems-with-bumblebee/

share|improve this answer
add comment

Ubuntu 12.04 is very new (this April), so how about trying instead the previous version 11.10 which is very stable and has great support. If you get that working without the overheating problem, you will have more than 95% (guessing) of 12.04 already, so you can get your teeth into that one. Later, when 12.04 has settled down (3 months?) you can upgrade it to 12.04 if you like.

share|improve this answer
add comment

Read completely-

A PPA repository exists that deal with being able to use the controls and FN keys of your samsung device.

You can add it by using the command:

sudo add-apt-repository ppa:voria/ppa

Now you need to upgrade your apt cache by using:

sudo apt-get update && sudo apt-get upgrade

Now you can install the 2 packages that give back access to FN keys:

sudo apt-get install samsung-tools
sudo apt-get install samsung-laptop

These packages will let you configure fan speeds which can help you reduce heating problems

You can find more information about the Voria packages here

You may also consider installing Jupiter along with it which lets you select the CPU performance modes...This also helps in reducing heating...

To Install Jupiter-

Open the terminal and enter the following commands-

sudo add-apt-repository ppa:webupd8team/jupiter

sudo apt-get update

sudo apt-get install jupiter

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.