Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my laptop, I have a faulty headphone socket, so when I insert headphones into it, the speakers do not mute. I can confirm that this problem is caused by faulty hardware and not software as when I twist the headphone jack, the speakers come on and off according to the movements.

On previous versions of Ubuntu, I worked around this problem by going into alsamixer and disabling "Auto-Mute Mode", and then going into the sound settings and choosing "Analog Headphones". However, on 12.04, no such option exists, rendering my headphones unusable with no way to work around the problem.

I momentarily thought I had this problem fixed when I installed PulseAudio Volume Control from the Software Centre. I selected the Output Devices tab, and under "Built-in Audio Analogue Stereo" I selected "Headphones" for the port. However, this almost randomly seems to change back to "Speakers", despite me setting "Auto-Mute Mode" as disabled.

Basically, I would like a way to permanently mute the speakers so only the headphones will play sound, without it losing my settings. It is ridiculous that such a simple setting has been taken away to "simplify" the user interface.

share|improve this question

3 Answers 3

This is what I did to stop the sound from being played from my built in speakers even when the headphones are connected.

  1. Goto "Ubuntu Software Centre", search for "GNOME ALSA Mixer" and install it.
  2. Reboot the machine if required.
  3. Open "GNOME ALSA Mixer". Check the 'Mute' below the column named "Mono". Uncheck the mute under other columns.
  4. Yippee ! You should now hear sound only from the headphones and not from the built in speakers.

Please try this and let me know if it works for you. This is for Ubuntu 12.04 LTS.

In case you don't see the column named "Mono", just try this out. In the GNOME ALSA Mixer, check active the headphone Jack Sense tab below the volume control options. This solved the problem for me.

share|improve this answer
    
Thanks, I'll try that now. –  Andy May 7 '12 at 11:45
    
There is no column named "Mute". I have Master, Headphones, Speaker, PCM, Mic, Mic Boost, Beep, Capture, and two columns named Internal. I have tried muting Speakers, but when I adjust the master volume, it just unmutes itself. –  Andy May 7 '12 at 12:03
    
The column name is "Mono" and not "Mute". For me, this "Mono" column appears between the columns "Beep" and "Capture". So when I muted this "Mono" column I was able to hear the audio only from the headphones. BTW, I have 32-bit Ubuntu 12.04 LTS installed on my desktop Dell Optiplex 960. –  Santhosh Rao May 7 '12 at 13:34
    
Apologies, I meant "Mono"; there is no such column of the name. I have 64-bit Ubuntu 12.04 LTS on an Acer Aspire 5552. –  Andy May 7 '12 at 17:24

There's a little app called Jack Audio Connection Kit that comes with Rakarrack that enables you to 'rewire' your audio inputs/outputs

http://rakarrack.sourceforge.net/

Might be worth a try.

share|improve this answer
    
I'll have a play with that. Thanks. –  Andy May 6 '12 at 18:48
    
When I click start, I get an error: D-BUS: JACK server could not be started. Sorry –  Andy May 6 '12 at 18:52
    
You can try searching Google for "D-BUS: JACK server could not be started" maybe?? –  Sun Dial May 6 '12 at 19:10
    
I did a search for you and this page is useful, if not a solution; it gives you a list of Jack commands which may be useful later on. trac.jackaudio.org/wiki/WalkThrough/User/jack_control –  Sun Dial May 6 '12 at 20:02

Open sound from preferences app. Click on output tab, and then choose the right output.

If this doesn't work, install PulseAudio. It will allow you to have control over were sound is transferred from your machine. Read, and follow instructions from here

share|improve this answer
    
I have tried this, but the two options are Built-in Audio and HDMI/Display Port. It is set to Built-in Audio, which covers speakers and headphones. Many thanks anyway. –  Andy May 6 '12 at 18:37
    
I edited the answer. See if Pulseaudio will help. –  Nico Bellic May 6 '12 at 18:51
    
PulseAudio is already installed by default, as it has been for quite a few versions. It says: "Ubuntu 8.04 and higher installs PulseAudio by default and no extra configuration is needed." –  Andy May 6 '12 at 18:58
    
But thanks anyway. –  Andy May 6 '12 at 18:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.