Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Software center not opening

I just installed Ubuntu 12.04 on my system and I can't install anything from the software center. When I click the install button nothing happens at all. No error, just doesn't work. I originally had these issues but the solution listed there worked for me. Installing packages from the command line with apt-get and dpkg works. I also tried following the advice in this thread but to no avail.

Edit: Running from the command line I get no messages when I try and click the install button but get a warning when it's started:

2012-05-06 12:14:04,481 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-05-06 12:14:04,536 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-05-06 12:14:04,988 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file

Edit 2: Seems I slightly stupid and just realized that it's disabled out (guess I'm not used to the Ubuntu GUI yet). Realizing this I googled and found this workaround, but still does anyone know of a solution?

share|improve this question

marked as duplicate by jokerdino, Eliah Kagan, Jorge Castro, Mitch, Tom Brossman Sep 8 '12 at 10:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
You could try and launch the software-center from the Terminal and the log messages (which are printed on the Terminal when you click on "Install" in the USC) might provide some clues. –  rhn-grg May 6 '12 at 16:05
    
Try doing a fresh installation of Software Centre from Synaptic Manager. –  atenz Jun 13 '12 at 18:09
    
My problem was fixed by getting new internet. I posted this as a solution and marked it but it was deleted for some reason. –  Fr33dan Jun 14 '12 at 14:43
    
I'm not sure how this is a duplicate of a question that was asked 4 months later. –  Fr33dan Nov 4 '13 at 15:31

2 Answers 2

Since the install button won't work, instead select the software you want to install by clicking on File on the top menu, and click "Install", and see if it will work.

share|improve this answer
    
I actually found that work around and mentioned it in my second edit. This is still not a true solution as it does not solve the problem. I believe it is a network related issue because getting new internet fixed it and it can no longer be replicated. –  Fr33dan Jul 17 '12 at 15:43

For me this was solved by doing

sudo software-center

in the terminal, essentially just starting it with the "right" privileges. Hops this solves your problem as well. Good luck

share|improve this answer
    
Thanks, but I tried that with no avail. –  Fr33dan May 14 '12 at 0:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.