Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell D630 laptop with an updated Ubuntu 12.04. It's not a clean installation, but an upgrade coming from 11.10.

After clicking on "shut down", the screen goes black but it keeps with the energy light on. It doesn't shut down. The system is up to date. Anyone with the same problem? Any fix?

share|improve this question
1  
This looks like your problem: bugs.launchpad.net/bugs/991977 . If yes, you should click on "yes, it affects me too". –  Andre May 19 '12 at 17:21
add comment

3 Answers

I have the same issue. I have two D630s, one running 12.04 with Unity and another running 12.04 with Gnome Shell.

When using Gnome Shell with the post-release updates driver I was unable to restart, on reverting to the version-current driver the system restarts normally.

When using Unity with the version-current driver I was unable to restart, on updating to the post-release updates driver the system restarts normally.

After changing the driver a restart is required for the new driver to kick in. This will be a manual restart but from then on your system should restart normally again.

Hope this helps anyone with the same annoying problem.

share|improve this answer
add comment

Note: Originally Posted by MrCorleone87 on this forum.

OK guys I think I might have a solution to your problems because I had the same problem on numerous distros when using NVIDIA (or ATI) drivers and it took me about 6 months to figure out what causes the problem. The freeze on reboot/shutdown doesn't happen with the Nouveau drivers but those are still not good enough to me. Although they're getting better.

So anyway, it is the boot splash that causes the problem. What you have to do is open your file manager as root. For those who don't know how to do it, you open the terminal and type sudo nautilus or su - c nautilus. Nautilus is obviously just an example , so if you're using thunar or pcmanfm you type in su -c thunar etc etc.

Now, you go to etc/default/grub and you look for the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and you change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

Then you look for the line:

#GRUB_GFXMODE=640x480

and you uncomment it and change the resolution to the actual resolution of your screen. (Mine is 1366x76)

Once you do that, you add an additional line right under and it goes like this:

GRUB_GFXPAYLOAD_LINUX=1366x768

So when you're done , everything should look like this:

GRUB_GFXMODE=1366x768
GRUB_GFXPAYLOAD_LINUX=1366x768

Now you save it, open a new terminal window and type in sudo update-grub. You reboot and that's it.

Obviously you won't have plymouth anymore but console output instead. However I think it's definitely worth it and I rather have working NVIDIA (or ATI) drivers without splash screen than the other way around. This solution works for me and it works for all the Ubuntu based distros. I hope it will work for you guys and let me know if it did. This was really bothering me for a long time

share|improve this answer
    
I have a Latitude D630 also and I have the same problem. This didn't work for me. It still wouldn't shut down –  dspyz Oct 6 '12 at 6:58
add comment

I had the same problem with my Dell Vostro 1500 and disabled the NVIDIA driver and it is working again! Go to "Additional Drivers" and see if the NVIDIA driver is activated, if so click remove to deactivate it.

share|improve this answer
    
Peter, you are right: If I disable the NVIDIA driver, it works, the laptop shut down normally. However, without that driver enabled, I cannot run Unity :-( Moreover, with Unity and the driver enabled, the CPU is over 1.5-2 all the time, and the fan running all the time. My guess is coming back to GNOME interface will solve the issues, but I would rather prefer to stay with Unity. –  Javi Vázquez May 12 '12 at 12:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.