Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 12.04 a month ago and am using it till now. I failed to notice that all this time there was no sound at all while running Ubuntu, even while playing a game in Wine. The weird thing is that only the startup sound comes when I log in (Indian/African drum tone), then comes the utter silence.

I tested both Digital Output (S/PDIF) and the speakers in the sound settings but can hear nothing.

Any help?

share|improve this question
I found a fix: just enable from BIOS to boot directly in the monitor where you want the hdmi/displayport sound from, it will activate the HDMI or Displayport sound of the monitor. And then you always can switch back and forward during the playback to hdmi and laptop sound, from the Ubuntu sound settings. – Szabi Mar 30 '13 at 18:53

15 Answers 15

up vote 14 down vote accepted

After searching, I have found a simple answer. Just execute

killall pulseaudio

Your speakers should work fine now. To ensure this, test the sound stack in System Settings > Sound > Test Sound (Speaker test, Not Digital Output (S/PDIF) test)

share|improve this answer
This worked for me -- Thinkpad T410 with Ubuntu 12.10. – nibot Jan 24 '13 at 8:56
Hm - it worked once, but then sound stopped working again, and was not revived by killing pulseaudio again. – nibot Jan 24 '13 at 10:34

Sometimes the problem is that alsa somehow got muted. Open a terminal and type:



and disable Auto-Mute Mode. The mute can be toggled with the M key.

share|improve this answer
Please add more details – Anwar Shah Jul 14 '12 at 7:13
worked for me, thanks alot – Ali Dehghani Jun 5 '13 at 17:17
See Alsamixer: howto disable auto-mute mode for a detailed answer! :-) – Mr. Polywhirl May 7 '14 at 2:02


killall pulseaudio

and go to System SettingsSoundOutput tab → ConnectorAnalog Output

This solved it for me.

share|improve this answer
There is no "connector" on 12.04, All I see are "Digital Output" and "Speakers" as options to select from... – Mr. Polywhirl May 7 '14 at 2:07

killall pulseaudio wasn't working for me. My issue was that I was not in the sound group.


gpasswd -a yourusername audio

Then do

killall pulseaudio

That worked for me.

share|improve this answer

Type alsamixer in the terminal.

Press F6 to select sound card and try switching to HDA Intel if available or something else apart from Nvidia. You might also want to increase a few settings that are low a little bit, like Mic and Mic boost.

Restart any application that might be running. This helped me enable skype sounds and hear the ringer.

If you check Applications > Multimedia > Pulseaudio Volume Control; in Output devices there should only be one device.

Hope this helps. Worked for me in Xubuntu 12.04.

share|improve this answer

Possible Fix

Remove the hidden .pulseaudio folder , log out and log back in. This might help in getting back the sound.

share|improve this answer
for me deleting the .pulse (there was no .pulseaudio) folder worked. Thanks. – kapcom01 Feb 7 at 16:41

Just in case nothing of the above works - check that the issue is not with the amplifier. I eventually plugged in another computer, and still silence.

Moving the cable to a different HDMI input of the amplifier did the trick. Who knows what is wrong with "HDMI3", but I can live with that. :-)

share|improve this answer

A a possible fix:

12.04 sound problem fixed

if 11.10 was ok for you, just use the 11.10 kernel, i used, check the link.

AND after that if you still don't hear anything do this steps:

SystemSettings -> Sound -> (Select output) SPEAKERS, NOT HDMI..

(what is worng with this Ubuntu dev guys... I never used HDMI output, make that setting seccondary, let me hunt how to enable when i need that crap... J)

P.S. what do you think fossfreedom is this post ok? comments should also be left, are the only feedback to developers, if they care.

share|improve this answer

You do not need to install a new kernel. You can install only another version of ALSA. You can try this daily build repositary of ALSA.

share|improve this answer

I did the following. Try it:

  1. Open terminal and typed alsamixer.

  2. Press a few tabs or F5 so you can see all the options.

  3. Now with your arrow keys go to loopback and enable it


share|improve this answer

Similar problem. Solution:

sudo su -
alsamixer -V all 

Press m to unmute the channels, as root.

share|improve this answer

What helped me is just bringing up the sound settings via the sound control (upper corner icon). And then testing the speakers.

share|improve this answer

I had no sound problem with Xubuntu 12.04 Beta on my HP laptop. After some googling I fixed it with setting HDMI Audio Profile to OFF in Application Menu - Multimedia - PulseAudio Volume Control - Configuration.

share|improve this answer
I'm sorry but I can't follow cause I cannot find 'Application > Multimedia > PulseAudio Volume Control > Configuration' on Ubuntu but I did try this 'alsamixer' on terminal and all were not set to mute if this is what you meant for volume control. – Mohd Arafat Hossain May 10 '12 at 2:57
You need to install pavcc – Shaneo1 Jul 14 '12 at 9:48

On ION 330 I had no sound over HDMI ... the solution was to run alsamixer and unmute S/PDIF 1.

share|improve this answer

In some cases reinstall the audio system can fix it.

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo alsa force-reload   

In some cases it may be necessary to use this ppa

sudo add-apt-repository ppa:ubuntu-audio-dev
sudo apt-get update
sudo apt-get dist-upgrade

FYI: When running a virtual machine with Ubuntu can cause some additional problems; treat it like a stand alone computer,reboot the virtual (VM ware/virtual-box/etc.) I followed the same command line in terminal and it work for me.


share|improve this answer

protected by Community Mar 30 '13 at 19:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.