Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After upgrading from 11.10 to 12.04, grub is completely broken. There seems to be an issue with the grub of the live image as well (amd64), it will not recognize my keyboard. (works in BIOS and after booting live usb).

I tried purging and reinstalling after chrooting from the live usb. I am able to update my system, but can't set up grub. I get an error message complaining about "unsupported RAID level: 149" What does it mean, there is no RAID set up for this machine? I tried reformatting the boot partition to no avail.

If booting from HD, I get stuck at grub text interface with no keyboard.

Any ideas what to try next?

EDIT: I reinstalled from usb which made my system bootable again, but still many problems. At least some of the problems appear to be related to the nvidia driver, as mentioned here: 12.04 and NVIDIA card problem with NVIDIA Geforce 7025 and removing the nvidia driver (keeping nouveau) seems to work better.

I also found out that the keyboard was set to OS in the BIOS, and setting it to BIOS gave me the keyboard back for the grub menu of the live usb system. Duh.

So many things turn out to be broken I think a clean install will be less of a pain than fixing it all.

share|improve this question Try a PS/2 keyboard if you have one and an aperture for one. Annoying bleeding bug. – user115704 Dec 19 '12 at 21:33
up vote 0 down vote accepted

and welcome! if you can make a copy on a CD of Super Grub Boot Disc from here..., you then boot up with this CD in the drive. It will find OSs and let you boot into them, them you can fix Grub by installing Grub Customizer by Daniel Richter. Good luck.

share|improve this answer
If Grub Customizer is just a front end to the grub tools, how is that going to fix the issue that I can't update the grub configurations with said tools? – user60950 May 6 '12 at 11:32
With SuperGrub you can boot your system from that disc, then re-install Grub to the HDD with Customizer. Every time I upgrade I get Grub problems, and these work a treat. It could be that your problem is deeper set though. Good Luck. – Sun Dial May 6 '12 at 12:00
SuperGrup made the liveusb work more predictably, and I tried reinstalling w/o reformatting, but still lots of stuff is broken. I will probably go for a clean install. Thanks for your suggestion. – user60950 May 8 '12 at 17:38
Update 8th May: I'm sure it's not an original idea, but I leapfrog from one Ubuntu issue to the next by having a spare partition ready for a fresh install, but I keep the older version going until I've completed the transfer. It's a bit of a pain rather than just upgrading, but it's nice to know you've got fresh foundations, rather than crumbs getting in the works from the old one. Glad you got it fixed anyway!! – Sun Dial May 8 '12 at 19:50

I had the same problem; I tried Super Grub, but selecting any of the OSes it finds to boot into leads to identical behavior, so it doesn't help at all. I also tried reinstalling Grub by booting into a livecd and manually mounting my hard drive, and that had no effect either. This problem seems rampant, so I hope someone comes up with a workable fix soon. I am very averse to reinstalling 11.10 from scratch as I inadvertently encrypted my home folder and I'm not confident I can decrypt it properly.

share|improve this answer

Grub2 and maybe grub1 is strange. I have Mint12 and Ubuntu 11/10 on my machine. This means I have two sets of grub2 menus and config files. (In fact 2 sets of /* ) If you edit one it may not be the one you are using. The one you are using depends on which OS was last loaded. I normally boot Mint 12 but now I find that yes I have LM12 as default and my KB is not effective till the OS is running. Ian.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.