Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Rhythmbox is not able to install the MPEG-4 plugin when I import mp4 files into it. It identifies the plugin(Gstreamer), but fails to install it citing package dependency errors as following:

 The following packages have unmet dependencies:

gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                      Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                      Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                      Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                      Depends: libglib2.0-0 (>= 2.31.2) but 2.32.1-0ubuntu2 is to be installed
                      Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1 is to be installed
                      Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                      Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                      Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                      Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
gstreamer0.10-ffmpeg:i386: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                           Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                           Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                           Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                           Depends: libglib2.0-0 (>= 2.31.2) but 2.32.1-0ubuntu2 is to be installed
                           Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1 is to be installed
                           Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                           Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                           Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                           Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
share|improve this question

1 Answer 1

Possible duplicate: Unmet dependencies for Media Players

Please try sudo apt-get install -f at the Terminal, as suggested in the above link.

share|improve this answer
    
I had already tried that and it is not helping. Following is the output: deep@deep:~$ sudo apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. –  Deepanjan Mazumdar May 6 '12 at 9:36
    
May be related to this bug. If you can manually install ffmpeg, vlc, it should also install most of the codecs. Use sudo apt-get install vlc ffmpeg. –  rhn-grg May 6 '12 at 15:50
    
I had vlc already installed, and this ffmpeg installation went through as well. Nevertheless, that particular plugin installation still fails. –  Deepanjan Mazumdar May 6 '12 at 19:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.