Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Before upgrading to 12.04, I completely backed up 11.10 oneiric with deja-dup. In 12.04 I had major nvidia-related problems, so I decided to roll back to 11.10.

I tried to restore from the backup and at first failed several times with "an uknown error occured". I reformated my hard drive, installed a fresh copy of 11.10 on the hard drive, and tried the restore again, with no success.

I then booted from a live usb and ran the restore again after mounting the file system. I chose the restore location to be "file system" and the restore completed successfully, or so it said.

After restarting my PC, all I got was a 'no operating system' error. I remounted my partition chrooted and installed the kernel.

I am working now but my question concerns the restore. Why didn't the restore worked? I'm hoping someone has thought of something that I have not.

share|improve this question

2 Answers 2

Deja Dup is only intended to back up your home directory files, not system files.

Reinstall 11.10, use the boot repair CD (search community for it) to fix boot problems, then restore to home directory with Deja Dup.

share|improve this answer

I know this probably is something that you have thought of but what about reinstalling 11.10 and then restoring your home directory to at least get going? I'm not sure about using Deja Dup as a bare metal restore tool (it might do it, I've just never thought of it that way) so this might be a way to get back to where you want to go.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.