Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded Xubuntu trough the wubi installer on Windows 7 and it worked just fine, But when i choose Xubuntu at the boot menu i get the NO WUBILDR error and then it just continues and I log on just fine... So far it hasn't effected Xubuntu much and i am able to continue using it, But seeing the error everytime is a bit annoying, how do i fix it? I've tried tons of thing's ive tried replacing the wubildr files with the one's in the winboot folder, and uninstalling/reinstalling, but nothing works. I've checked tons of other websites and forums and the likes and havent found anything that will fix it.

share|improve this question
add comment

2 Answers

Wubi uses Grub4Dos (wubildr.mbr). Part of it's job is to find it's second stage (wubildr). It looks on all partitions and outputs a diagnostic if it can't find it.

Something like this would mean that the first partition is FAT32 and there is no /wubildr:

Try (hd0,0): FAT32: No wubildr

This isn't an error. You can copy the wubildr to the root of the first partition to stop it showing, or just ignore it (my recommendation).

There is another message that shows on all Wubi installs:

Error: 'prefix' not set

There's nothing you can do to get rid of this. (No known workarounds). It's registered as a bug. My advice, is to ignore it, or install a normal dual boot if it bothers you that much.

share|improve this answer
add comment

Why don't you just check out this forum. it may help you the most. I am sick of writing long solutions. osrry, its early in the morning and I haven't slept yet.
http://ubuntuforums.org/showthread.php?t=1639198

One similar problem stating same is here:
http://ubuntuforums.org/showthread.php?t=1878427

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.