Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use the Faenza icon collection in Ubuntu 12.04 Unity with no issues. I decided to change my Gimp launcher icon, so I made my own (gimp-ak.png) and added it, and its appropriately sized derivatives, to the Faenza icon folders:

/usr/share/icons/Faenza/apps/16/gimp-ak.png
/usr/share/icons/Faenza/apps/22/gimp-ak.png
/usr/share/icons/Faenza/apps/24/gimp-ak.png
/usr/share/icons/Faenza/apps/32/gimp-ak.png
/usr/share/icons/Faenza/apps/48/gimp-ak.png
/usr/share/icons/Faenza/apps/64/gimp-ak.png
/usr/share/icons/Faenza/apps/96/gimp-ak.png
/usr/share/icons/Faenza/apps/scalable/gimp-ak.svg

I then updated the Icon field in /usr/share/applications/gimp.desktop from "gimp" to "gimp-ak":

[Desktop Entry]
Version=1.0
Type=Application
Name=GIMP Image Editor
GenericName=Image Editor
Comment=Create images and edit photographs
Exec=gimp-2.6 %U
TryExec=gimp-2.6
Icon=gimp-ak
Terminal=false
Categories=Graphics;2DGraphics;RasterGraphics;GTK;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=GIMP
X-GNOME-Bugzilla-Component=General
X-GNOME-Bugzilla-Version=2.6.12
X-GNOME-Bugzilla-OtherBinaries=gimp-2.6
StartupNotify=true
MimeType=application/postscript;application/pdf;image/bmp;image/g3fax;image/gif;image/x-$
X-Ubuntu-Gettext-Domain=gimp20

After logging off (and even restarting), my custom icon does not show up - Gimp has the default gear icon:

enter image description here

Setting the Icon field in gimp.desktop to any other icon in the Faenza collection works fine. What do I need to do to get my custom icon to show up properly?

share|improve this question
    
Have you checked for a competing .desktop file in ~/.local/shared/applications? –  YMOZ May 5 '12 at 23:40
    
I have a ~/.local/share/applications (no "d" on the share folder), and there is only one file: mimeapps.list Would the issue be a competing .desktop file when any other icon in the Faenza collection works - it's just my custom icon that does not? –  Alex K May 8 '12 at 0:11
    
my way > create new folder for Faenza icon. let say FaenzaRIP and replace your new gimp icon. Using command : gsettings set org.gnome.desktop.interface icon-theme 'FaenzaRIP' –  penreturns Aug 30 '12 at 17:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.