Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

enter image description hereMy newly installed Ubuntu 12.04 gnome-classic just turned into chinese locale after reboot, how do I change it back to English?

I can't find any language menus, and the ones I opened are, well, in chinese...

When I open a terminal and execute gnome-language-selector, I get lots of this in the prompt:

locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory

Any ideas?

If I go to the Language section in Users, I only get the options in the picture.

share|improve this question
    
I solved it following the instructions of this post: askubuntu.com/questions/2855/locale-reset-lost-settings –  213441265152351 May 5 '12 at 22:50
add comment

marked as duplicate by Tachyons, Flimm, Luis Alvarado Apr 19 '13 at 16:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4 Answers

up vote 3 down vote accepted

I'd recommend you login into the Unity session, because I'm not sure where I can find all of these options in a Gnome Classic session.


Click on your username in the upper right corner of the screen, and choose the bottom option in the menu that pops out.

User menu

In the dialog that opens, the second option allows you to change your language.

User account

Change it back to English, or whatever language you like. Then, reboot.

share|improve this answer
add comment

Solution:

  1. Edit /etc/default/locale:

    LANG="en_US"
    LANGUAGE="en_US:en"
    
  2. Edit ~/.pam_environment:

    LANG=en_US
    Language=en_US
    

Logout and Login or Reboot.

share|improve this answer
3  
Worked for me, was hard to navigate menus in chinese... –  Martin Hansen Jul 20 '12 at 0:17
2  
Worked here too, especially after editing the second file (.pam_enviroment) - Thanks! –  techexpert Aug 11 '12 at 0:26
add comment

I have the same problem y I solved just one min ago.

You have to select the first language option, and then relogin the Gnome session.

NOTE: if you do any changes from the Unity session, you will not sew a result.

Cheers!

share|improve this answer
add comment

Having just faced a similar issue, I resolved it by translating my language choice into traditional Chinese using Google Translate, then pattern-matched. In the screenshot in the question, the first entry translates as "English" and the second as "English (United Kingdom)". Picking one and logging out then in should reset the UI.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.