Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use virtualbox 4.1.14 directly from the developers including the extension (not the ppa) on an ubuntu 11.10 system.

I try to access the internet from the kubuntu live cd that I have booted inside the VM. I think the external environments shouldn't play such a big role for the VM. I chose NAT for Adapter 1, "Intel Pro/1000 MT Server (82545EM)" as someone on the net recommended that.

I tried it with DHCP within kubuntu. Since kubuntu showed that it had no IP address, I also tried it manually and by executing dhclient manually. Using these two ways, I got local IPs, but I am not sure what the right settings for static IPs for the virtual machine are.

When I try to reach in rekonq, the site is not available, although rekonq "loads" several seconds. I also tried to replace the DNS server by the IP of my router/IAD.

Even when I ping google's IP from within the virtual machine, "the destination host is unreachable".

share|improve this question
up vote 2 down vote accepted

have you tried to select wlan interface after choosing "Bridged Adapter"? And I dont think that you will need to configure manual IP, just let it to be assigned automatically by DHCP. It will be of the same range as the host's

share|improve this answer
You mean as "Name"? There is no such entry, but eth1 is my wlan interface and I chose that. What "Adapter Type" do I need to chose below that? If this interface is directly connected to my router: The DHCP server of the router is off. – jubel May 6 '12 at 8:34
I am using version 4.1.12 and I have the option to choose the interface as "name", after selecting "bridged adapter". The selected adapter type is "PCnet-FAST III". And in my virtual machine it shows like a wired connection, you have to select the ssid and put the password at your host's wlan interface. – GTO69 May 6 '12 at 9:52
Thank you very much, that was the right answer! It only works with the adapter type "PCnet-FAST III" and not the Intel ones. I rebooted my machine to make sure its the choice of the adapters. Yes, it is. So I understood it right, no need for the ssid in the VM. The machine also appears with the MAC of the host. – jubel May 6 '12 at 17:05

You may have more luck by using a Bridged Adapter mode which hooks into the networking interface of your choice, thereby piggybacking off of the host system's internet connection.

In cases where NAT does not automatically work on your system, using Bridged Adapter mode tends to work.

share|improve this answer
I tried this as well now. Do I get it right that I configure this interface in kubuntu as I did in the host (just another IP address) as if it was a physical device like the host? I also put the MAC address of this interface in the MAC filter. But I can't put in a SID or a passphrase since this shows up as a wired connection. Still no luck. – jubel May 5 '12 at 22:39
Thank you very much! Bridging was correct and needed as well. – jubel May 6 '12 at 17:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.