Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've upgraded from 10.10 to 12.04. The situation: I plug the dongle in and enter the password. If I click 'Enable Mobile Broadband' and I get a notice on the top right saying 'GSM network. You are now registered on the home network'. At this stage I have not actually connected and when I click my broadband connection i see that 'Enable Mobile Boardband' is unticked AGAIN and I cannot connect to my broadbnad connection when I click it.

share|improve this question

I should follow the solution provided by alexfish in this thread at Ubuntuforums, which applies to Ubuntu 12.04, and discusses how your modem can be recognised and set up to work correctly.

share|improve this answer
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Imagine the linked site goes down for maintenance, or even forever: Your post would be useless to someone having the problem outlined here. – hexafraction Aug 13 '12 at 16:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.