Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Updated from 11.10 to 12.04 after fresh install, often the lock screen will give me a black screen with a mouse cursor instead of the usual. This occurs most often while the Ubuntu software center is open or left unattended for a long period of time.

I have a mouse cursor I can move and even select the area where I would enter my password. If typed in and I press enter I can no longer select the text area like it logged in, yet still have a black screen.

I can enter the terminal and the Ctrl+Alt+Del to restart the computer in order to get back in. Is there any fix for this or a way to get back to the GUI without restarting the whole computer?

share|improve this question

closed as off topic by fossfreedom Jun 8 '12 at 9:07

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

This a bug: - please log into Launchpad and mark yourself as being affected. – David Edwards Jun 8 '12 at 8:35
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. – fossfreedom Jun 8 '12 at 9:07
up vote 1 down vote accepted

Get to the terminal and try to type:

sudo restart lightdm

This will erase all unsaved work but it will restart the display manager, and will let you to login again.

share|improve this answer
Thank you so much. Any thoughts on what is causing it? – schonjones May 5 '12 at 17:38
Some app might be taking lots of CPU time, so ubuntu doesn't have enough of it to get you back to your desktop. – LiquidPL May 5 '12 at 17:42
Crazy I was using 11.10 before and had no issues, but I also went to a true install over the wubi install I had before. – schonjones May 5 '12 at 18:00
Ok so there is definitely a relation to this issue and software center running. I've run virtualbox in the background as well as other software with out repeating this problem. can I safely remove and reinstall software center to try to fix the problem? If so how? – schonjones May 7 '12 at 2:43

I narrowed this problem down to being exclusively related to Software Center running. Removing and reinstalling Software Center solved this issue.

share|improve this answer
I'm having the EXACT problem, but I don't have Software Centre open. I upgraded from 11.10 to 12.04. I am using a HDMI connection. After resuming from suspend, sometimes screen will be blank with mouse cursor, and mouse changes to I-beam where the password box normally is. I can enter my pw and login but still can only see the mouse only. So same issue, just no SW Center running. I will try reinstalling it anyway as it worked for you... – nLinked May 11 '12 at 21:28
I did reinstall it and haven't had the problem since! Funny though, I never had SW Center open anyway. Thanks though! – nLinked May 13 '12 at 18:26
Had the same problem with 12.04LTS on an old Dell laptop. Solved as recommended with sudo apt-get remove software-center ; sudo apt-get install software-center – Diomidis Spinellis Jan 9 '13 at 21:59

Relatively easy solution is to do ALT+PrintScr/SysRq+K You get log off

But hope that this is temporarely solution

share|improve this answer
Does this save changes in LibreOffice documents if they have been open at the time? – king_julien Sep 8 '13 at 6:43
No, not only LibreOffice, this will infact make you loose any unsaved changes. I use the terminal & vim so one nice workaround is to just use tmux (or screen) and since it is runs it's own server even if you restart lightdm any unsaved changes or tasks running in the tmux will not quit and you just reattach it on resume. Quite helpful. – Dhruva Sagar Jul 9 '14 at 4:38

I've again had this same issue so reinstalling SW Center hasn't worked. But a quick fix on the black screen is to press Ctrl Alt F1, and then Ctrl Alt F7. The logon screen then appears with its GUI.

share|improve this answer
After recent updates I am having the same problem again. it apears to be a compiz problem, but when I try to restart it, it hangs and never finishes reloading, but If I have firefox open can usually get back to it, but not unity. – schonjones May 22 '12 at 20:47
Pressing CTRL+ALT+F1 and then CTRL+ALT+F7 does not bring back the login screen. How would it do that? – benjaoming Aug 8 '12 at 10:00

Solved. Disable automatic screen lock in "Brightness & Lock" settings. If it doesn't work for you (mine froze screen after wakeup), try installing xfce but keep using unity. Notifications changed a bit, but freezing problem disappeared.

share|improve this answer
In my household I need a screenlock was curious about the xfce instalation while still keeping unity. How is this accomplished? – schonjones May 22 '12 at 20:49
Simply by clicking on the circular ubuntu logo next to your username in the login screen and selecting unity as your desktop environment. – Pepos May 24 '12 at 12:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.