Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to share my Ubuntu's 12.04 (Desktop) wireless (wlan0) internet connection with a Freesat box through ethernet (eth0).

I've set up the wired connection IPv4 settings "Share with other computers" and I'm getting a wired connection but unfortunately the Freesat box can't seem to automatically configure the network settings.

Available Manual Network Settings (Freesat Box):

IP Address, Subnet Mask, Router Address, DNS Address

If I try to configure the freesat box manually will I need to configure the wired (eth0) settings differently in Ubuntu.

share|improve this question


I just spent the better part of the day getting Internet Connection Sharing via Network Manager to work on Maya. The problem is that my installation didn't have a /etc/resolv.conf. If you're connecting via DHCP, you don't need one, but apparently Network Manager's Internet Connection Sharing does.

So do "sudo gedit /etc/resolv.conf" and (assume you get a blank file) enter in this, replacing the bracketed items of course:

domain [YourDomain]
nameserver [YourPrimaryNameserver]
nameserver [YourSecondaryNameserver]

You can get the primary and secondary nameserver IPs by right-clicking on Network Manager and selecting "Connection Information" and making sure you're on the tab for your Internet connected network device.

As soon as I made my resolv.conf and rebooted, the device I was sharing found the Internet with no problem as all.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.