Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Ubuntu 12.04 and I love it. However I have one problem- I am unable to shutdown or reboot properly.

When I shutdown my laptop (Acer Aspire 5560) it hangs on the 5 dots and stays there.

When I reboot my laptop it does shutdown but when it boots back up it stay's on the Purple screen (no logo what so ever)

Thing's I've I'd to stop this:

  • sudo service network-manager stop before shutdown - nothing

  • Adding some lines the the GRUB file - nothing

  • installed other Ubuntu versions - nothing
  • sudo shutdown -h now - nothing

and some more.

At the moment I see a black screen in front of me with the text

 Asking all remaining processes to terminate [OK]

And the 5 dots with only the last one orange.

On other tries I got this thing:

modem-manager:could not get the system bus......

I first had Ubuntu dual boot Windows. And then it worked fine. However after a fresh install of Ubuntu alone I got this.

share|improve this question
1  
Update: now got an error: "unmount: /run/lock: not mounted" "Will now halt" –  Max Beer May 5 '12 at 15:51
1  
I think it has something to do with the power management on the Acer and the board is not getting the proper signal or misinterpreting the signal it gets. I've got the same model and working on the same issue. –  user62033 May 9 '12 at 14:18
1  
Update: installed other distros (mint, fedora) both work! This means it has something to do with ubuntu itself and not my laptop. –  Max Beer May 11 '12 at 19:21
    
I am experiencing the same problem on my Acer laptop. This was not like this before when I fresh installed Ubuntu. I guess an update must have caused this for me. Does the fixes suggested below work? –  ultrajohn Sep 12 '12 at 22:44

6 Answers 6

I had a similar problem with a Dell XPS 15z which I resolved by adding acpi=noirq to the kernel arguments:

sudo vi /etc/default/grub

set

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash"

then

sudo update-grub

Note that previously I had been using acpi=off, which permitted me to boot, but not shutdown. Without any acpi flag, I was not able to boot.

share|improve this answer
1  
This did the trick for me, thanks. Running 12.04 64-bit on a Dell XPS M1530. –  Gemini14 Jun 29 '12 at 23:35
    
How exactly do you update the grub? I mean when I type sudo vi /etc/default/grub the grub file appears in the terminal. But how do I edit it? –  Barman Jul 5 '13 at 13:01
1  
@Barman This link should help you keyxl.com/aaab462/105/VIM-Text-Editor-keyboard-shortcuts.htm –  Sashwat Aug 11 '13 at 16:20
    
This didn't worked for me –  Sashwat Apr 30 at 9:01
    
Adding acpi=noirq fixed the reboot problem but also disable my builtin keyboard and mouse. I can only use my laptop using external mouse and keyboard. –  ninjascorner Jul 23 at 3:27

You may try to these commands into terminal

For shutdown

sudo halt

For shutdown

sudo init 0

For restart

sudo init 6

For shutdown

 sudo shutdown -h now

For hibernate

sudo /etc/acpi/hibernate.sh
share|improve this answer
    
Too bad, all failed. Still stuck on the ubuntu logo with 5 dots. –  Max Beer May 6 '12 at 9:15

The only thing that I needed to do was to press Ctrl+Alt+T to open the terminal. When it opens, run the command below

sudo update-grub

and now it's working fine.

share|improve this answer

Same issue with spurious hangs "on the 5 dots". I've read somewhere (cannot remember where) to first "Log Out" (top right corner menu) and then shutdown. I've been doing this for more than one month now with no more issue.

share|improve this answer

I got a hack from this link -- http://www.pbehnke.com/main/node/11, for some reason if the usb controls are set to auto, the shutdown-reboot loop starts. The solution was to make them on forcefully.

I have added a function in the /etc/init.d/halt script like this --

# Add this function in the /etc/init.d/halt script
# call before do_stop
set_usbs_on () {
    usbcontrolpath="/sys/bus/usb/devices/*/power/control"
    for dev in $usbcontrolpath;
    do
        echo "Setting $dev: " `cat $dev` "to on"
        echo on > $dev
        echo ""
    done
}

and I call it before do_stop in case $1 stop switch --

stop)
    set_usbs_on
    do_stop
    ;;

Now the machine shuts down.

share|improve this answer

Usings Ctrl+Alt+T to open the terminal and running run the command below

sudo update-grub

solved same shutdown problem on old Dell Optiplex desktop running Lubuntu 13.04 and testing saucy salamander.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.