Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't understand how to drag files into running application. For example:

  1. I have an image on my desktop or a folder and I want to drag it into libreoffice writer.
  2. I have files that I want to attach to an email I am composing.

How do I do this?

The only solution i found is to resize the window and then drag the files into the resised application but this is not quick as i would like to do it, specially on netbooks

Everything was so easy on gnome2.

share|improve this question
    
You can remove unity and install gnome classic if you wish. –  harisibrahimkv May 5 '12 at 15:43
    
"I can't understand how to drag files into running application." versus "esize the window and then drag the files into the resised application". So you do understand how but do not like it !? Then change desktop evironment to one that does it differently ... –  Rinzwind May 5 '12 at 16:23

2 Answers 2

There has been a bug filed https://bugs.launchpad.net/unity/+bug/995039.

Another workaround in Evolution is to copy the files to the clipboard and then pasting it into the message, but seems that Evolution only accepts this once then greys out the paste function in the right-click menu.

Changing DE should not be necessary unless they mark the bug as a "will not fix" as the bug breaks desktop paradigm.

Good luck.

share|improve this answer
    
I dont use evolution, I would like to be able to do this with all the applications, like i was doing before, now it's just not working at all :( –  Richez May 8 '12 at 8:14

Try this workaround, working for me in certain cases, not everything.

  1. Super+D in order to hide all windows from the foreground.
  2. Start dragging your desired object.
  3. Super+D in order to bring back all windows to the foreground.
  4. Drop it on your desired application.

Of course: it will be really useful if you have the application in the foreground before starting this procedure.

I hope this help.

Good luck!

share|improve this answer
    
Suped+D does nothing on my ubuntu 12.04 –  Richez May 8 '12 at 8:12
    
Super+D usually hide/show all active windows, this is usually configured on Preferences/Keyboard Shortcuts. Certain functions have been disabled from its original behavior in 12.04. Try setting up your key bindings to Super+D in order to hide all windows and focus the Desktop and give this a try again. Anyway, this will only work if your desired objects are in the desktop. –  Geppettvs D'Constanzo May 8 '12 at 15:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.