Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I thought I would try 12.04 installation on a spare laptop still running 10.04 rather than on my main laptop running on 11.10. I installed 12.04 over rather than clean.

Fine… But I cannot login as my normal user (only as a guest) so I cannot get benefits of over installation. When I try to login as my user and use my password, I get the following message:

Could not update ICEauthority file /home/username/.ICEauthority

Though my password is valid for superuser applications.

Since then I changed the password via the passwrd command, but I still get the same error message.

Do you have any suggestions ? If not I will run a clean installation I guess.

share|improve this question

3 Answers 3

I also had the same problem and just fixed it.

The main problem I had was when upgrading I used the same user id as before. But Ubuntu actually created a new user and associated the home directory to my previous users folder. As a result all my old files were associated with my older user id and was not accessible to my new ip.

So doing a chown should fix it:

sudo chown -R user:group ~/*
share|improve this answer

You should be able to login as root from the grub screen if you can get working (if it doesn't normally show, do left shift during boot). It should be possible to reset the password for your account from the root terminal once you have it. Just thought; when you say 'installed over' ... you didn't use wubi did you?

share|improve this answer
    
no no wubi just installed after looking at live cd trial..I can login but not as myself –  Antony May 5 '12 at 15:37
    
Update..so I changed the password via the cammand passwrd ..Still same message...could not update ICEauthority file /home/username/.ICEauthority –  Antony May 5 '12 at 16:14
  • Switch to the text console [Ctrl][Alt][F1]
  • Login with your username / password
  • Check for errors, write them down word for word. Did you enter your home directory?
  • Check the output for ls -l /home. Does it say drwx at the start of the line, notice especially the w?
  • Check for nearly full filesystems df -h
  • Type exit
  • Switch to the graphics console [Ctrl][Alt][F7]
  • If you had any errors on the text console, add them to your question.
share|improve this answer
    
Hi you mean looking for errors after I login?...Nope none –  Antony May 5 '12 at 16:02
    
Do the other checks too, copy the output in your question. –  jippie May 5 '12 at 16:27
    
I did.Seems all ok.The fact is there appears to be no .ICEauthority file –  Antony May 5 '12 at 18:09
    
What is the output to mount? Copy it to your question. Same for ls -l /home /username /home/username/.ICEauthority –  jippie May 6 '12 at 5:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.