Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to add an network printer (HP Laserjet 9050) using the LPD protocol. On previous Ubuntu version I was shown a dialog box with Installable Options where I could specify total printer memory, whether it was a duplex unit, whether to use Tray 1 or Tray 4, etc. However in Ubuntu 12.04, I am not given those options anymore. I am now unable to use the network printer. Can someone help me?

share|improve this question

3 Answers 3

Program for configuring printer is system-config-printer.

Try following in terminal or Alt+F2

$ system-config-printer
share|improve this answer
    
That's what I was doing, but never mind I found the solution. –  ajaxfiore May 7 '12 at 0:47

After much browsing around I found that the problem was the ppd file being provided by the foomatic-db-compressed-ppds. Somehow the ppd now is different. So I went here: http://hplipopensource.com/hplip-web/index.html

And instead of downloading the file to install hplip, I downloaded the tarball http://sourceforge.net/projects/hplip/files/hplip/3.12.4/hplip-3.12.4.tar.gz/download

I extracted it and was able to find the hp-laserjet_9050-ps.ppd in the folder hplip-3.12.4/prnt/ps

I used that one to install the network printer and it worked perfectly.

share|improve this answer

alt-F2 gave me an error but terminal brought up the printer config box, thanks I have a Kyocera EP C170N With the new system the auto detect works much better to get you up and running with basic settings but I needed the PPD to be able to print in colour as the default foomatic only gave me greyscale on my colour laser :P

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.