Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm experiencing some problems with drive cache and I don't know what's causing these problems. This is my dmesg:

[11690.011238] sd 6:0:0:0: [sdb] Asking for cache data failed
[11690.011248] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[11741.720851] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
[11741.722965] sd 6:0:0:0: [sdb] Asking for cache data failed
[11741.722975] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[11793.433011] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
[11793.435347] sd 6:0:0:0: [sdb] Asking for cache data failed
[11793.435356] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[11845.140846] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
[11845.143098] sd 6:0:0:0: [sdb] Asking for cache data failed
[11845.143102] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[11896.856723] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled

There are hundreds of these lines. It is happening since I've installed Ubuntu 12.04 64bit beta2 from my pendrive. Now I don't have anything at /dev/sdb. I don't know if these errors are making my system less responsive, but I think that dmesg shouldn't look like this.

My kernel version: 3.2.0-24-generic.

Do you have any idea how to solve it?

Thank you in advance.

share|improve this question

marked as duplicate by Flimm, Eric Carvalho, Basharat Sialvi, user68186, bcbc May 14 '13 at 19:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
awesome, I did have a microsSD card reader on my laptop. I had the adapter in but not SD card installed and as soon as I removed the adapter the errors stopped awsomeer.... :) I hate seeing errors in my logfiles, like to have everything running as 100% as I possibly can, thanks thanks thanks :) –  user110371 Nov 24 '12 at 11:44
add comment

6 Answers 6

up vote 9 down vote accepted

I'm having the same issue on the official 12.04 LTS relase i also believe it is causing the system to be less responsive. According to some sources it's harmless. (i can apparently only post 2 links)

The following thinks this is error output from an onboard card reader:

https://bbs.archlinux.org/viewtopic.php?pid=1059099

It's confirmed to be an upstream issue in

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/987993

Run lsusb and find the offending device

nathan@Ham-Bone:~$ lsusb 

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader

In my case it's the Realtek multicard reader which a quick check of

$ dmesg | grep realtek
[    4.716068] usbcore: registered new interface driver ums-realtek
$ lsmod | grep realtek
ums_realtek            17920  0 

reveals a module ums-realtek

$sudo rmmod ums_realtek

Fixes the problem in a reversible way for me. That is

$sudo modprobe ums_realtek

enables the card reader again. I haven't tested if it works since I never use it.

If this doesn't work there are some other ways to disable usb devices by unbinding them in the /sys/ directory.

share|improve this answer
    
I should add you can also blacklist the module if you never use it –  Nate Iverson May 6 '12 at 18:37
    
It seems like we have the same device that is causing the problem. Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader Hope they will solve it soon. Thanks –  mescam May 13 '12 at 19:23
    
It appears that a recent kernel update has fixed the problem. :) –  Nate Iverson Jun 3 '12 at 16:03
add comment

I met the same issue on my 12.04 server installed on EEEBox. I found a workaround way is insert a sd card into usb reader, then these kind messages will not come out. But I do not want use this way, anyone else know another solution? Thanks

share|improve this answer
add comment

i was getting the same issue after i installed ubuntu 12.04 server. I installed gedit to alter the logging level(dont laugh about the fact that i use gedit). When gedit was installing it also installed many archive packages from ubuntu.com. After installation i left my monitor on and the pc untouched to see if it happens again and it didnt. This seems to have solved the issue for me. Im not saying go and install gedit but there maybe away to install the archive packages that come with gedit. Hope this helps.

share|improve this answer
1  
Gedit is installed on desktop ubuntu by default, so packages on which it depends should be present too. –  mescam May 30 '12 at 22:11
add comment

I found that loading the driver with option ss_en=0 works. Doing

echo "ums-realtek ss_en=0" |sudo tee -a /etc/modules

makes the change permanent.

Further explanation:

While trying to discover why this message happens, I looked into the options for the two modules involved, ums-realtek and usb-storage. I did not feel that loading and unloading the ums-realtek module every time was a suitable solution, as I am often using the card reader.

Checking module options:

# modinfo ums-realtek 
  parm: auto_delink_en  enable auto delink (int)
  parm: ss_en           enable selective suspend (int)
  parm: ss_delay        seconds to delay before entering selective suspend (int)

Research into what these options were for did not yield any result, and I did not feel inclined to bother the author by email. Since this driver uses the usb-storage as well, I felt the "suspend" option might be enabled by default ( perhaps to conserve battery on laptops ) and the messages a result of wakeup-query-suspend sequences. Since I didn't care if the device was constantly powered on or not, I tried setting this option to 0 (off) and it works.

share|improve this answer
    
FYI: this same workaround is mentioned in a bug-report about this issue: bugs.launchpad.net/ubuntu/+source/linux/+bug/925760/comments/75 –  Mark May 9 '13 at 13:39
add comment

Unloading the driver works for me ! I never use the cardreader so this was a fine option otherwise I would have set the 'ss_en=0' option.

share|improve this answer
add comment

I got the same output in dmesg when I inadvertently had gotten the IDE connector to a disk one step misaligned at the IDE to USB adapter. That may be the cause of your problem.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.