Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I enable nvidia drivers in recovery mode?

I've installed 12.04 via text mode with the alternate ISO. It rebooted into the blank purple screen; Ubuntu bongos played. I'm in recovery mode. Apt says the nvidia-common is installed. jockey-text says nvidia-current and nvidia-current-updates are both installed but not enabled. It complains it cannot find the module for either.

share|improve this question
    
Check which module is loaded with lsmod | grep -e nvidia -e nouveau. Try running nvidia-xconfig. –  mikewhatever May 5 '12 at 14:39
    
lsmod says nvidia is loaded. I'm root in recovery and it can't find nvidia-xconfig. Neither can locate and whereis. –  jonc May 5 '12 at 14:44
    
Nuts. Make that "noveau is loaded." –  jonc May 5 '12 at 15:00
    
Ran apt-get update and apt-get upgrade in recovery. Got a new kernel. Rebooted. No go. Back in recovery, ran "Clean". That added a kernel. Reboot. No go, again. lsmod still says nouveau is loaded. "jockey-text --no-dbus -l" still says nvdia_current/nvidia_current_updates are "disabled, not in use". –  jonc May 5 '12 at 15:20
    
You can permanently blacklist nouveau with echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf. –  mikewhatever May 5 '12 at 16:34
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.