Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So basically yesterday I downloaded the 12.04, And I created a Live USB, And booted it on my Laptop. Everything was great, Everything worked.

Then I needed to do something on windows, And when I logged into Windows, I couldnt access Internet. I tried to set up new network, But it prompted me that no network hardware found!

Then I proceeded to check the device manager, And sure enough all network related hardware had exclamations marks beside it. When I checked properties, It said it is not working because cant load drivers. I even browsed to location where those drivers supposed to be, And all corresponding files are there.

Anyone knows what could have happened?

share|improve this question
There is no way that Live USB session "did something wrong" with your existing installation of any OS, unless you manually mount that OS partition and play with its system files, look into your device manager in Windows to see if your network cards are shown up there... – Kushal May 5 '12 at 12:32
Did you boot the usb or did you insert it while Windows was running and carry out a wubi installation? – barrydrake May 5 '12 at 13:14
Yeah I was thinking that as well.. Just found it to be to much a co incidencem that it happened right after that. Yeah all the devices are showing up, it just says that cant load drivers – vgaldikas May 5 '12 at 13:14
No i didnt do wubi. I just booteed it. – vgaldikas May 5 '12 at 13:43

Don't know Windows 7, but in earlier version of Windows, the device manager allows you to remove the ones that are marked with the exclamation mark. After that, Windows 'finds' the new hardware and offers to re-install the drivers. Really though this is a Windows problem, not one that is on topic here.

share|improve this answer
Well I am aware that it is windows problem. I just thought that ubuntu had something to do with it :) – vgaldikas May 5 '12 at 14:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.