Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Ubuntu 12.04 LTS on my Aspire 3820TG which comes with an Artheros AR9287. Somehow the Wireless performance is to put it mildly sub-optimal. I thought it might have something to do with the Txpower which is only at 13 dBm but unfortunately I'm unable to set it to a higher level. Any ideas how to increase the sending power or how to improve the performance in general?

Thanks a lot in advance


share|improve this question

This bug has been driving me nuts for several months. I tried several fixes (nohwcrypt=1, blacklisting various drivers, etc.) Nothing worked for more than a few minutes until I tried the solution here:

The place to download the updated kernel stuff is here:

(I have precise, not quantal, but it doesn't seem to make a difference.)

You will need to get the following header packages:

  • linux-headers specific to your architecture (i386 or x64)
  • linux-headers (all)

You will also need to get the following kernel packages:

  • linux-image for your architecture
  • linux-image-extras for your architecture

Once you have the packages, you can install each one like this:

sudo dpkg -i (name of file)

That done, reboot the machine, and you should be good.

After running for half an hour, this is the statistics (mtr) for pinging my router:

Loss%   Snt   Last   Avg  Best  Wrst StDev
 0.1%  1715    2.0   4.6   1.5 460.1  21.0

This is NOT as reliable as it is in Windows, so I think the driver maintainers still have some work to do. However, it's orders of magnitude better than it was before!

share|improve this answer

I had the same problem on another chipset. I solved it by updating the kernel from 3.2 to 3.4.

This is how to install this kernel:

However the only little problem i had with this kernel, was that Nvidia propietary drivers was dissapeared.

share|improve this answer
Can you edit this answer to include information about how to install kernel version 3.4 on an Ubuntu 12.04 LTS system? (And, if you know, what any pitfalls or disadvantages might be to using this kernel version.) – Eliah Kagan May 23 '12 at 17:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.