Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 64-bit (running as a VM on VMWare Player). The keyboard shortcut for Workspace switcher indicates that Ctrl+Alt+ arrow keys switches to the desired workspace.

enter image description here

While this works for Up/Down arows, using Ctrl+Alt+ Left/Right doesn't seem to work - the switcher doesn't move to the desired workspace.

Am I doing something wrong here?

share|improve this question
    
Are you running under VMWare Player? Because I have this problem as well, and unity --reset doesn't fit it. –  SCdF May 15 '12 at 8:53
    
@SCdF yes, I'm running it under VMWare Player! –  Sathya May 15 '12 at 9:46
add comment

1 Answer 1

up vote 11 down vote accepted

So as noted in Sathya's comment, he is running under Vmware.

The reason this doesn't work is because VMware Player is taking control of Ctrl+Alt, because that's the key combination it uses to "break out" of the VM.

There are two ways you can fix this:

Override

There is an escape override built into VMware which overrides the breakout combination, by tapping Space while holding down the breakout combination, before hitting your desired key So for example, if you wanted to go to the right workspace you would hold down Ctrl+Alt, tap Space and then tap Right.

Change the Combination

Change the breakout combination. To do this, edit preferences.ini (in Windows 7 it's in C:\Users\$YOUR_USERNAME$\AppData\Roaming\VMware, if you can't find it search) and add:

pref.hotkey.shift = "true"
pref.hotkey.alt = "true"
pref.hotkey.control = "true"

This remaps the breakout combination to Ctrl+Alt+Shift.

Before you say anything, yes, I realise that this is also used in Ubuntu, to move windows between workspaces. Unfortunately, that is the best I've been able to come up with so far. You are supposed to be able to be as specific as left or right control, but they don't work for me, leftControl etc just maps back to both.

References:

share|improve this answer
    
Perfect, works well. Thanks a lot! –  Sathya May 15 '12 at 14:26
    
Or you can add Win key to that combination and it will not interfere with normal shortcuts - askubuntu.com/a/106612/104730 –  Donatas Olsevičius Feb 22 '13 at 8:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.