Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading from 11.10 to 12.04 (having solved the problem of Ubuntu being a cock and booting into Low Res Graphics mode) I now keep receiving:

'Sorry, Ubuntu has suffered an internal program error.'

Each time it seems to give a different file location as the problem. Then, as if that wasn't enough, I send a Problem Report and that crashes too.

These crashes are random. Also, and I don't know if this is related, I suffer complete, random system crashes. It can be minutes or, hours, after booting. It just goes blank and I have to press the power button. After I reboot, one or, both, of my 2TB External HDDs cannot be mounted by Ubuntu because they were not unmounted correctly. The actual advice given by Ubuntu is to plug them into a Windows system. I do and they can be read perfectly.

Can anyone help?

share|improve this question
    
I am having the same error. My computer does not shutdown ... I have to plug it off. –  Santosh Linkha May 5 '12 at 18:34

1 Answer 1

Random crashes like this are often the symptom of hardware failure, particularly RAM. I suggest you run the memory test option available to you from the initial bootloader (or from the LiveCD you installed from).

While my current install of Precise has had it's crashes, they've been consistently the same programs. A random distribution of processes, and the crash reporter itself crashing, would not be consistent with a programming error.

On the matter of your external drives, they are probably formatted with the NTFS file system ; Linux doesn't really have a satisfactory NTFS filesystem check / fix (fsck) utility, because NTFS is a poorly documented proprietary file system - this is one of those things that are upsetting you about Windows. Linux will politely refuse to mount NTFS volumes that have not been unmounted correctly (as happens in a crash), because it's less than certain about it's ability to fix problems. You can force them to mount manually, but the best solution is probably to mount them in Windows (sigh) and shut it down properly, which should rectify the problem.

If you need a file system to exchange files with Windows, FAT32 is probably the best choice, since it does have a functional fsck utility. As an older file system, this involves compromise. It's also possible to mount ext2 in Windows, as long as you install additional file system drivers, but if you want to exchange files with machines you don't have admin privileges on, that isn't an option.

But your first concern should really be to diagnose what seems to be a hardware issue.

share|improve this answer
    
I would agree with everything you said here, except that none of this happened until I upgraded to 12.04. 11.10 had no problem mounting my NTFS drives and my system did not randomly crash. These problems are new. The laptop is the same this week as it was last week and it was serviced about a month ago. The memory test found no issues, that was one of the first things I ran... –  Mark L. Potts May 5 '12 at 13:05
    
It's really sad, all modern Linux desktop distros are notoriously unstable. I blame the short release cycles. 12.04 at least is an LTS edition but it is worrying that they plumbed to go LTS on such an unstable version. –  tomwrong Jun 30 '12 at 10:51

protected by Community May 8 '12 at 19:18

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.