Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 12.04 on my old ibook G3 (Since I wiped the HDD)

Now luckily I have a WiFi Ethernet bridge on my PC to give the ibook Internet. But even when it is connected to eth0 (LAN) it keeps asking to connect to eth1 (Wi-Fi) the router is using WPA2 Personal with AES

I was just wondering, because the router is upstairs and the ibook is downstairs next to my PC. and the WiFi connects upstairs, but I can't use it up there cos the battery is junk and I got no plugs that'll reach.

share|improve this question
add comment

6 Answers 6

This worked for me:

  1. Edit Connections [network connections]
  2. Delete all existing wired and wireless connections
  3. Reboot
  4. Connect to wireless network and enter password
  5. Fixed!

The reboot is necessary, didn't work for me until I rebooted.

share|improve this answer
    
your answer is correct but you shouldn't have to delete any wired connections. –  Stephen Myall May 28 '12 at 19:41
    
Yes, just delete the wireless you're trying to connect to. –  Alaa Ali Jun 6 '13 at 5:53
add comment

What i did was open the connection (Edit Connections), opened the one i use (Edit...), and in the Wireless Security did:

  • enter the Key (which used to be here, but after upgrade miraculously disappeared);

  • checked Available to all users.

now it works fine. i have no idea why the problem even occurred.

share|improve this answer
    
By "key", you mean the WPA or WEP key/password right? –  YatharthROCK May 11 '13 at 15:12
add comment

I have a similar issue and it seems that my roommates ISP is blocking me. Details at question "Internet Service Provider only supports Microsoft OSes" This answer seems to be useful and I am trying it out. Perhaps it will work for you.

You might be helped by the Firefox extension User Agent Switcher

Then if a website asks what you're running, Firefox can disguise itself as Internet Explorer running on a Windows machine. Though, if the website requests something like ActiveX (a feature of only IE), Firefox will not be able to process the request.

Answered by Sepero

share|improve this answer
add comment

I had this same problem on a 32 bit system using an Anthros AR9285 wireless driver.
The wireless would boot up perfectly fine. After a while the wireless would disconnect, then continue to ask for my password but never connecting again. My system log (/var/log/syslog) was constantly reporting network errors. I had to either reboot, or suspend the system to get it to work again.

It was interesting because, I had a previous 12.04 install on the same machine, which worked just fine. The problem started after I did a fresh 12.04 install. The new install had the linux-generic kernel.

The problem stopped after I installed the linux pae kernel. There is some really good documentation about pae here: https://help.ubuntu.com/community/EnablingPAE

You can install the pae kernel: sudo apt-get install linux-generic-pae linux-headers-generic-pae

This is an extremely frustrating problem and hope this solution may help.

share|improve this answer
add comment

I could not connect to anything and was asked for password every 30 seconds. Went to Edit Connections and deleted the wired and wireless connections completely, rebooted and re-entered the password and now works OK. At last I have the same Ubuntu working on my PC and laptop, and will hopefully be able to be free of Windows in the near future!

share|improve this answer
add comment

My wi-fi was working fine and all the sudden I got the same problem on ubuntu 12.04 (desktop) and fedora 17 (laptop), at the same time. Using Windows 7 I could establish wifi connection, but with some problems. My wifes laptop with Windows 8 established connection with no problems.

Soft router restart solved the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.