Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I (linux newbie) have a Dell XPS 17 and tried to install Ubuntu 12.04. After installation all WLAN accesspoints near are detected. But I can not connect (but I am able to connect with other computers as well as with Dell XPS 17 under windows). Outputs:

iwconfig

  lo        no wireless extensions.

  wlan0     IEEE 802.11bg  ESSID:"LerchenPoint"  
      Mode:Managed  Frequency:2.412 GHz  Access Point: 58:6D:8F:A0:2D:58   
      Bit Rate=1 Mb/s   Tx-Power=14 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:off
      Link Quality=70/70  Signal level=-37 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:19   Missed beacon:0

  eth0      no wireless extensions.

sudo lshw -class network

*-network               
   description: Wireless interface
   product: Centrino Wireless-N 1000
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:04:00.0
   logical name: wlan0
   version: 00
   serial: 00:26:c7:99:98:28
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-24-generic firmware=39.31.5.1 build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bg
   resources: irq:50 memory:f0400000-f0401fff
*-network
   description: Ethernet interface
   product: RTL8111/8168B PCI Express Gigabit Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:0a:00.0
   logical name: eth0
   version: 06
   serial: f0:4d:a2:56:e3:94
   size: 1Gbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp
   mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8168e-2.fw ip=192.168.0.123 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
   resources: irq:47 ioport:6000(size=256) memory:f0a04000-f0a04fff memory:f0a00000-f0a03fff

dmesg | grep iwl

[   10.157531] iwlwifi 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   10.157561] iwlwifi 0000:04:00.0: setting latency timer to 64
[   10.157598] iwlwifi 0000:04:00.0: pci_resource_len = 0x00002000
[   10.157599] iwlwifi 0000:04:00.0: pci_resource_base = ffffc90011090000
[   10.157601] iwlwifi 0000:04:00.0: HW Revision ID = 0x0
[   10.157731] iwlwifi 0000:04:00.0: irq 50 for MSI/MSI-X
[   10.157834] iwlwifi 0000:04:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[   10.157976] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[   10.179772] iwlwifi 0000:04:00.0: device EEPROM VER=0x15d, CALIB=0x6
[   10.179775] iwlwifi 0000:04:00.0: Device SKU: 0X50
[   10.179777] iwlwifi 0000:04:00.0: Valid Tx ant: 0X1, Valid Rx ant: 0X3
[   10.179796] iwlwifi 0000:04:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[   10.574728] iwlwifi 0000:04:00.0: loaded firmware version 39.31.5.1 build 35138
[   10.726409] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   19.714132] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[   19.777862] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[ 2251.603089] iwlwifi 0000:04:00.0: PCI INT A disabled
[ 2266.578350] iwlwifi 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 2266.578399] iwlwifi 0000:04:00.0: setting latency timer to 64
[ 2266.578435] iwlwifi 0000:04:00.0: pci_resource_len = 0x00002000
[ 2266.578437] iwlwifi 0000:04:00.0: pci_resource_base = ffffc90011090000
[ 2266.578439] iwlwifi 0000:04:00.0: HW Revision ID = 0x0
[ 2266.578704] iwlwifi 0000:04:00.0: irq 50 for MSI/MSI-X
[ 2266.578808] iwlwifi 0000:04:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[ 2266.578916] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[ 2266.600709] iwlwifi 0000:04:00.0: device EEPROM VER=0x15d, CALIB=0x6
[ 2266.600712] iwlwifi 0000:04:00.0: Device SKU: 0X50
[ 2266.600713] iwlwifi 0000:04:00.0: Valid Tx ant: 0X1, Valid Rx ant: 0X3
[ 2266.600727] iwlwifi 0000:04:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[ 2266.605978] iwlwifi 0000:04:00.0: loaded firmware version 39.31.5.1 build 35138
[ 2266.606331] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[ 2266.614179] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[ 2266.681541] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S

Solutions I tried:

rfkill list all

0: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

options iwlwifi 11n_disable=1
sudo modprobe -rfv iwlwifi
  WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be 
  ignored in a future release.
  rmmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
  rmmod /lib/modules/3.2.0-24-generic/kernel/net/mac80211/mac80211.ko
  rmmod /lib/modules/3.2.0-24-generic/kernel/net/wireless/cfg80211.ko
sudo modprobe iwlwifi
  WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be 
  ignored in a future release.

replacing iwlwifi-1000-5.ucode (current driver) against iwlwifi-1000-3.ucode

sudo jockey-gtk:

(jockey-gtk:2493): Gtk-CRITICAL **: gtk_icon_set_render_icon_pixbuf: assertion icon_set != NULL' failed (jockey-gtk:2493): Gtk-CRITICAL **:   gtk_icon_set_render_icon_pixbuf: assertion icon_set != NULL' failed 

nothing is listet in "Additional drivers" (german: "Zusätzliche Treiber").

gksudo gedit /etc/modprobe.d/blacklist.conf

add "blacklist acer_wmi"

Any help would be appreciated very much.

Thanks!!

share|improve this question
    
Run "sudo jockey-gtk" in terminal and check if there any restricted WIFI driver listed. If yes then install and reboot the machine. If it's not there then need to further investigate the issue. –  Abhijeet May 5 '12 at 7:58
    
sudo jockey-gtk: (jockey-gtk:2493): Gtk-CRITICAL **: gtk_icon_set_render_icon_pixbuf: assertion icon_set != NULL' failed (jockey-gtk:2493): Gtk-CRITICAL **: gtk_icon_set_render_icon_pixbuf: assertion icon_set != NULL' failed nothing is listet in "Additional drivers" (german: "Zusätzliche Treiber". –  user60622 May 5 '12 at 8:08
    
Did not you get any gui? Otherwise run it from Unity dash. –  Abhijeet May 5 '12 at 8:20
    
I got the gui. But nothing was listed. It looks the same if I start it from the Unity dash (german: Systemeinstellungen) –  user60622 May 5 '12 at 8:21
add comment

2 Answers

I've got a Dell XPS 17 (l702x) with an n-1000 I'd like to get working under Ubuntu 12.04 (once I install it). So, lending heavily from this post:

The fix seems to involve downgrading the n-1000's firmware.

Please downgrade the firmware with iwlwifi-1000-ucode-128.50.3.1.tgz (for ease, save it to your desktop). You can right-click it and select 'Extract' or issue the following at a terminal prompt:

tar xzvf ~/Desktop/iwlwifi-1000-ucode-128.50.3.1.tgz 

Again, in the terminal, back up the current firmware:

sudo mv /lib/firmware/iwlwifi-1000-5.ucode /lib/firmware/iwlwifi-1000-5.bak

Now copy over the downloaded firmware:

cd Desktop/iwlwifi-1000-ucode-128.50.3.1/
cp iwlwifi-1000-3.ucode iwlwifi-1000-5.ucode
sudo cp iwlwifi-1000-5.ucode /lib/firmware
sudo modprobe -r iwlagn
sudo modprobe iwlagn

Now let's see what happened under the hood:

dmesg | tail -n20

This has been tested and confirmed in the original post, and is said to be a permanent fix (i.e. is still working after a reboot).

best of luck!

share|improve this answer
add comment

Before you do all that, check your BIOS settings.

I have the same machine and, every once in a while, it will report that wireless is disabled by hardware switch.

It happens only when I suspend the machine while plugged into an ethernet wired connection and then wake it up expecting to use wireless only.

The wireless "button" above the keyboard will not turn it back on, so I have to go into BIOS to re-enable it. Save, reboot, enable wireless in Network Connections and everything's back to normal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.