Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Skype by downloading the .deb file from their website. The installation aborted due to unmet dependencies and Skype was not installed by Ubuntu Software Center. From then on, I couldn't install any packages and none of the package management utilities worked: they all complained of unmet dependencies.

I tried

 sudo apt-get install -f

It couldn't fix the issue. Here is the output from the command

 tutysra@tutysra-devel:~$ sudo apt-get install -f Reading package
 lists... Done Building dependency tree        Reading state
 information... Done Correcting dependencies... Done The following
 packages were automatically installed and are no longer required:  
 libsdl-ttf2.0-0 libsdl-mixer1.2 libsdl-image1.2 libmikmod2
 libsdl-net1.2   libboost-regex1.46.1 Use 'apt-get autoremove' to
 remove them. The following extra packages will be installed:  
 libqt4-declarative:i386 libqt4-designer:i386 libqt4-opengl:i386  
 libqt4-qt3support:i386 libqt4-scripttools:i386 libqt4-sql-mysql:i386  
 libqt4-sql-sqlite libqt4-svg:i386 libqt4-test:i386 libqtgui4:i386
 qdbus Suggested packages:   libqt4-declarative-folderlistmodel:i386
 libqt4-declarative-gestures:i386   libqt4-declarative-particles:i386
 libqt4-declarative-shaders:i386   qt4-qmlviewer:i386 libqt4-dev:i386
 libqt4-dev qt4-qtconfig:i386 The following packages will be upgraded: 
 libqt4-declarative:i386 libqt4-designer:i386 libqt4-opengl:i386  
 libqt4-qt3support:i386 libqt4-scripttools:i386 libqt4-sql-mysql:i386  
 libqt4-sql-sqlite libqt4-svg:i386 libqt4-test:i386 libqtgui4:i386
 qdbus 11 upgraded, 0 newly installed, 0 to remove and 61 not upgraded.
 21 not fully installed or removed. Need to get 0 B/10.7 MB of
 archives. After this operation, 1,024 B of additional disk space will
 be used. Do you want to continue [Y/n]? y (Reading database ... 172294
 files and directories currently installed.) Preparing to replace
 libqt4-sql-sqlite 4:4.8.1-0ubuntu4 (using
 .../libqt4-sql-sqlite_4%3a4.8.1-0ubuntu4.1_amd64.deb) ... Unpacking
 replacement libqt4-sql-sqlite ... Preparing to replace qdbus
 4:4.8.1-0ubuntu4 (using .../qdbus_4%3a4.8.1-0ubuntu4.1_amd64.deb) ...
 Unpacking replacement qdbus ... Processing triggers for man-db ...
 dpkg: error processing libqtgui4:i386 (--configure):  libqtgui4:i386
 4:4.8.1-0ubuntu4 cannot be configured because libqtgui4:amd64 is in a
 different version (4:4.8.1-0ubuntu4.1) dpkg: error processing
 libqt4-declarative:i386 (--configure):  libqt4-declarative:i386
 4:4.8.1-0ubuntu4 cannot be configured because libqt4-declarative:amd64
 is in a different version (4:4.8.1-0ubuntu4.1) dpkg: error processing
 libqt4-svg:i386 (--configure):  libqt4-svg:i386 4:4.8.1-0ubuntu4
 cannot be configured because libqt4-svg:amd64 is in a different
 version (4:4.8.1-0ubuntu4.1) dpkg: error processing libqtgui4
 (--configure):  libqtgui4:amd64 4:4.8.1-0ubuntu4.1 cannot be
 configured because libqtgui4:i386 is in a different version
 (4:4.8.1-0ubuntu4) dpkg: error processing libqt4-declarative
 (--configure):  libqt4-declarative:amd64 4:4.8.1-0ubuntu4.1 cannot be
 configured because libqt4-declarative:i386 is in a different version
 (4:4.8.1-0ubuntu4) E: Sub-process /usr/bin/dpkg returned an error code
 (1)

I tried removing libqt4-test by sudo apt-get remove -f libqt4-test but couldn't since the package manager refused to remove it without resolving the unmet dependencies.

I ran dpkg --configure -a and this was the output:

 tutysra@tutysra-devel:~$ sudo dpkg --configure -a dpkg: error
 processing libqtgui4 (--configure):  libqtgui4:amd64
 4:4.8.1-0ubuntu4.1 cannot be configured because libqtgui4:i386 is in a
 different version (4:4.8.1-0ubuntu4) dpkg: error processing
 libqtgui4:i386 (--configure):  libqtgui4:i386 4:4.8.1-0ubuntu4 cannot
 be configured because libqtgui4:amd64 is in a different version
 (4:4.8.1-0ubuntu4.1) dpkg: dependency problems prevent configuration
 of ia32-libs-multiarch:i386:  ia32-libs-multiarch:i386 depends on
 libqtgui4; however:   Package libqtgui4:i386 is not configured yet.
 dpkg: error processing ia32-libs-multiarch:i386 (--configure): 
 dependency problems - leaving unconfigured dpkg: error processing
 libqt4-declarative (--configure):  libqt4-declarative:amd64
 4:4.8.1-0ubuntu4.1 cannot be configured because
 libqt4-declarative:i386 is in a different version (4:4.8.1-0ubuntu4)
 dpkg: error processing libqt4-declarative:i386 (--configure): 
 libqt4-declarative:i386 4:4.8.1-0ubuntu4 cannot be configured because
 libqt4-declarative:amd64 is in a different version
 (4:4.8.1-0ubuntu4.1) dpkg: error processing libqt4-svg (--configure): 
 libqt4-svg:amd64 4:4.8.1-0ubuntu4.1 cannot be configured because
 libqt4-svg:i386 is in a different version (4:4.8.1-0ubuntu4) dpkg:
 error processing libqt4-svg:i386 (--configure):  libqt4-svg:i386
 4:4.8.1-0ubuntu4 cannot be configured because libqt4-svg:amd64 is in a
 different version (4:4.8.1-0ubuntu4.1) dpkg: error processing
 libqt4-sql-mysql (--configure):  libqt4-sql-mysql:amd64
 4:4.8.1-0ubuntu4.1 cannot be configured because libqt4-sql-mysql:i386
 is in a different version (4:4.8.1-0ubuntu4) dpkg: error processing
 libqt4-sql-mysql:i386 (--configure):  libqt4-sql-mysql:i386
 4:4.8.1-0ubuntu4 cannot be configured because libqt4-sql-mysql:amd64
 is in a different version (4:4.8.1-0ubuntu4.1) dpkg: dependency
 problems prevent configuration of ia32-libs:  ia32-libs depends on
 ia32-libs-multiarch; however:   Package ia32-libs-multiarch is not
 installed.   Package ia32-libs-multiarch:i386 is not configured yet.
 dpkg: error processing ia32-libs (--configure):  dependency problems -
 leaving unconfigured dpkg: error processing libqt4-opengl
 (--configure):  libqt4-opengl:amd64 4:4.8.1-0ubuntu4.1 cannot be
 configured because libqt4-opengl:i386 is in a different version
 (4:4.8.1-0ubuntu4) dpkg: error processing libqt4-opengl:i386
 (--configure):  libqt4-opengl:i386 4:4.8.1-0ubuntu4 cannot be
 configured because libqt4-opengl:amd64 is in a different version
 (4:4.8.1-0ubuntu4.1) dpkg: dependency problems prevent configuration
 of libqtwebkit4:i386:  libqtwebkit4:i386 depends on libqtgui4 (>=
 4:4.8.0); however:   Package libqtgui4:i386 is not configured yet.
 dpkg: error processing libqtwebkit4:i386 (--configure):  dependency
 problems - leaving unconfigured dpkg: error processing libqt4-designer
 (--configure):  libqt4-designer:amd64 4:4.8.1-0ubuntu4.1 cannot be
 configured because libqt4-designer:i386 is in a different version
 (4:4.8.1-0ubuntu4) dpkg: error processing libqt4-designer:i386
 (--configure):  libqt4-designer:i386 4:4.8.1-0ubuntu4 cannot be
 configured because libqt4-designer:amd64 is in a different version
 (4:4.8.1-0ubuntu4.1) dpkg: dependency problems prevent configuration
 of libqt4-help:  libqt4-help depends on libqtgui4 (=
 4:4.8.1-0ubuntu4.1); however:   Package libqtgui4 is not configured
 yet. dpkg: error processing libqt4-help (--configure):  dependency
 problems - leaving unconfigured dpkg: error processing
 libqt4-scripttools (--configure):  libqt4-scripttools:amd64
 4:4.8.1-0ubuntu4.1 cannot be configured because
 libqt4-scripttools:i386 is in a different version (4:4.8.1-0ubuntu4)
 dpkg: error processing libqt4-scripttools:i386 (--configure): 
 libqt4-scripttools:i386 4:4.8.1-0ubuntu4 cannot be configured because
 libqt4-scripttools:amd64 is in a different version
 (4:4.8.1-0ubuntu4.1) dpkg: dependency problems prevent configuration
 of libqt4-qt3support:i386:  libqt4-qt3support:i386 depends on
 libqt4-designer (= 4:4.8.1-0ubuntu4); however:   Package
 libqt4-designer:i386 is not configured yet.  libqt4-qt3support:i386
 depends on libqt4-network (= 4:4.8.1-0ubuntu4); however:   Version of
 libqt4-network:i386 on system is 4:4.8.1-0ubuntu4.1. 
 libqt4-qt3support:i386 depends on libqt4-sql (= 4:4.8.1-0ubuntu4);
 however:   Version of libqt4-sql:i386 on system is 4:4.8.1-0ubuntu4.1.
 libqt4-qt3support:i386 depends on libqt4-xml (= 4:4.8.1-0ubuntu4);
 however:   Version of libqt4-xml:i386 on system is 4:4.8.1-0ubuntu4.1.
 libqt4-qt3support:i386 depends on libqtcore4 (= 4:4.8.1-0ubuntu4);
 however:   Version of libqtcore4:i386 on system is 4:4.8.1-0ubuntu4.1.
 libqt4-qt3support:i386 depends on libqtgui4 (= 4:4.8.1-0ubuntu4);
 however:   Package libqtgui4:i386 is not configured yet. dpkg: error
 processing libqt4-qt3support:i386 (--configure):  dependency problems
 - leaving unconfigured dpkg: error processing libqt4-test (--configure):  libqt4-test:amd64 4:4.8.1-0ubuntu4.1 cannot be
 configured because libqt4-test:i386 is in a different version
 (4:4.8.1-0ubuntu4) dpkg: error processing libqt4-test:i386
 (--configure):  libqt4-test:i386 4:4.8.1-0ubuntu4 cannot be configured
 because libqt4-test:amd64 is in a different version
 (4:4.8.1-0ubuntu4.1) Errors were encountered while processing: 
 libqtgui4  libqtgui4:i386  ia32-libs-multiarch:i386 
 libqt4-declarative  libqt4-declarative:i386  libqt4-svg 
 libqt4-svg:i386  libqt4-sql-mysql  libqt4-sql-mysql:i386  ia32-libs 
 libqt4-opengl  libqt4-opengl:i386  libqtwebkit4:i386  libqt4-designer 
 libqt4-designer:i386  libqt4-help  libqt4-scripttools 
 libqt4-scripttools:i386  libqt4-qt3support:i386  libqt4-test 
 libqt4-test:i386

I require some help/pointers on resolving this issue.

share|improve this question
2  
The formatting in your question is badly broken, and cannot easily be fixed. If you paste the text from the Terminal into your question again, you can select it and use the <$> tool to format it properly. Blockquotes should not be used for code (unless you're quoting it from another source, in which case the code should typically be in a code block which itself is enclosed in a blockquote). –  Eliah Kagan Jul 7 '12 at 12:32
add comment

2 Answers 2

sudo aptitude reinstall libqtcore4:i386 fixed it.

If you do not have aptitude installed, and since apt-get is broke, you will need to download and install the deb manually (and any missing dependencies) using

dpkg -i

http://packages.ubuntu.com/precise/admin/aptitude

share|improve this answer
add comment

This is common problem in 64 bits for installing ubuntu

First a downgrade is required and done with the following: create the 'preferences' file:

sudo vi /etc/apt/preferences

and insert the following lines:

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

Pin-Priority must be greater than 1000.

Then you may downgrade the offending applications with:

sudo apt-get dist-upgrade

Then you may install packages that complained about dependencies, like
sudo apt-get install ia32-libs-multiarch, or sudo apt-get install ia32-libs.

Finally, you should remove the file you just created:

sudo rm /etc/apt/preferences

Now download Skype From Official website(skype.com ) for multi architecture

then open the downloded package from software center then you should able to install skype

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.