Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Upgrading Gimp gives the following error:

Preparing to replace gimp 2.6.12-1ubuntu1 (using .../gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb) ...
Unpacking replacement gimp ...
dpkg: error processing /var/cache/apt/archives/gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/gimp/2.0/plug-ins/file-xmc', which is also in package gimp-plugin-registry 3.5.4-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
add comment

5 Answers

up vote 2 down vote accepted

You didn't correctly remove gimp-plugin-registry and it's still giving conflicts as seen in error messages. Try:

sudo apt-get update
sudo dpkg --purge gimp gimp-plugin-registry
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get install gimp
share|improve this answer
    
thank you m_gol. I tied and successed,but also need remove gimp-gmic. detail infos: dpaste.com/743555 –  kafeitu May 6 '12 at 5:18
    
@kafeitu I can't tell, did this solve the problem for you as it did for me (Hooray)? If so you should accept the answer. –  Dennis May 8 '12 at 1:26
    
Thank you, for you have helped me resolve my ubuntu box from boot failure after installing GIMP 2.8. You are a life saver. –  Julio May 20 '12 at 20:19
add comment

You should have removed the GIMP Plugin Registry package before upgrading :

sudo apt-get remove gimp-plugin-registry

because the package hasn't been compiled with GIMP 2.8 support.

Now , run the following:

sudo apt-get dist-upgrade

Source

share|improve this answer
    
I tried it,but still error, detail infos to visit: dpaste.com/743166 –  kafeitu May 5 '12 at 8:41
    
@kafeitu try sudo apt-get -f install , and if still there is an error you'll need to purge the ppa and start over the installation process. –  Binarylife May 5 '12 at 9:19
add comment

I think you should reinstall GIMP. After you uninstalled it typeapt-get install gimp in the terminal to install it.

share|improve this answer
    
I tried too, error infos: dpaste.com/743167 –  kafeitu May 5 '12 at 8:43
add comment
  1. Before updating GIMP from 2.6 to 2.8, you will have to install Ubuntu Tweak from the terminal with:

    sudo add-apt-repository ppa:tualatrix/ppa

    sudo apt-get update

    sudo apt-get install ubuntu-tweak

    Note: Ignore if you have it.

  2. Open Ubuntu Tweak --> Admin tab --> Source center --> Image.

  3. Check Gimp 2.8 RC and click Refresh button at the bottom.
  4. Now open Update Manager from launcher and find updates for Gimp 2.8.
  5. Install updates and enjoy.
share|improve this answer
add comment

first try to upgrade it.Otherwise try this:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update && sudo apt-get install gimp
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.