Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've looked around for answers to this question, But none of them seem to work for my particular problem. Obviously my USB headset isn't working, But I might as well share the scenario. I am running Ubuntu 12.04 and I have a Logitech USB headset. The relevant output from dmesg is as follows:

[160708.528047] usb 2-1.2: USB disconnect, device number 9
[160768.890123] usb 2-1.2: new full-speed USB device number 10 using ehci_hcd
[160768.997578] input: Logitech Logitech USB Headset as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.3/input/input15
[160768.997795] generic-usb 0003:046D:0A0C.0005: input,hidraw0: USB HID v1.00 Device [Logitech Logitech USB Headset] on usb-0000:00:1d.0-1.2/input3

When I go to System Settings -> Sound, My headset shows up in both the Output and Input tabs, It is called "Clear Chat Comfort USB Headset" in those tabs, But I doubt that's a serious issue.

When I click my headset in either tab to use it, The changes are not remembered when I reopen the sound settings, the built-in audio is still used. Also when I select the headset in the Output tab, and click the Test Sound button to test everything, The sound still comes from my laptop's onboard audio, instead of from my USB headset.

Does anyone know how to correct this? I am stumped.

share|improve this question

3 Answers 3

Finally the headset is usable now. I just did an update recently, also additionally I've updated from the ppa:ubuntu-audio-dev/ppa

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa

sudo apt-get update; sudo apt-get dist-upgrade -y

Now the usb headset is on the input and output tabs. input tab

enter image description here

share|improve this answer
    
This worked great! Not sure why suddenly it was removed from the list as it was working about a month ago :/ One thing I noticed though is after a reboot having the USB Logitech device plugged in caused my machine to hang. It could have just been due to it needing to properly configure things -- not sure but now it's working after I rebooted without it attached. –  shaneonabike Oct 20 '12 at 18:56
    
This worked for me, had to restar after the update, but it worked! Thanks! –  Deleteman Dec 4 '12 at 16:54

I opened system settings->sound. In that open Hardware tab. It shows logitech USB headset. Now click on Test Speakers, Front left, right. After this I able to get the audio from the headset.

share|improve this answer
    
My headset was working fine until I put the PC in standby. After resuming, it stopped working. Doing this fixed it. –  Roger Lipscombe Aug 23 '13 at 7:05

This may not be your problem, but I had similar trouble with a plantronics usb headset and found my solution here.

share|improve this answer

protected by Community Apr 3 at 18:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.