Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 12.04. I recently performed an upgrade for my system. Now, when I try to install a package (aptitude for example), I see this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
aptitude is already the newest version.
aptitude set to manually installed.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libqt4-dbus : Depends: libqt4-xml (= 4:4.8.1-0ubuntu4) but 4:4.8.1-0ubuntu4.1 is to be installed
           Depends: libqtcore4 (= 4:4.8.1-0ubuntu4) but 4:4.8.1-0ubuntu4.1 is to be installed
           Recommends: qdbus (= 4:4.8.1-0ubuntu4)
           Breaks: libqt4-dbus:i386 (!= 4:4.8.1-0ubuntu4) but 4:4.8.1-0ubuntu4.1 is to be installed
libqt4-dbus:i386 : Breaks: libqt4-dbus (!= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4 is to be installed
libqt4-network : Depends: libqt4-dbus (= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4 is to be installed
libqt4-script : Depends: libqt4-dbus (= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4 is to be installed
qdbus : Depends: libqt4-dbus (= 4:4.8.1-0ubuntu4.1) but 4:4.8.1-0ubuntu4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I then proceeded to run sudo apt-get install -f to fix the dependency problem. When I ran that, I received this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libqt4-dbus
The following packages will be upgraded:
  libqt4-dbus
1 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
23 not fully installed or removed.
Need to get 0 B/179 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y

dpkg: error processing libqt4-dbus (--configure):
 libqt4-dbus:amd64 4:4.8.1-0ubuntu4 cannot be configured because libqt4-dbus:i386 is in a different version (4:4.8.1-0ubuntu4.1)

dpkg: dependency problems prevent configuration of qdbus:
 qdbus depends on libqt4-dbus (= 4:4.8.1-0ubuntu4.1); however:

  Version of libqt4-dbus on system is 4:4.8.1-0ubuntu4.
dpkg: error processing qdbus (--configure):

 dependency problems - leaving unconfigured
dpkg: error processing libqt4-dbus:i386 (--configure):

 libqt4-dbus:i386 4:4.8.1-0ubuntu4.1 cannot be configured because libqt4-dbus:amd64 is in a different version (4:4.8.1-0ubuntu4)

dpkg: dependency problems prevent configuration of libqt4-network:i386:

 libqt4-network:i386 depends on libqt4-dbus (= 4:4.8.1-0ubuntu4.1); however:

  Package libqt4-dbus:i386 is not configured yet.
dpkg: error processing libqt4-network:i386 (--configure):

 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-network:
 libqt4-network depends on libqt4-dbus (= 4:4.8.1-0ubuntu4.1); however:

  Version of libqt4-dbus on system is 4:4.8.1-0ubuntu4.
dpkg: error processing libqt4-network (--configure):

 dependencNo apport report written because the error message indicates its a followup error from a previous failure.

No apport report written because the error message indicates its a followup error from a previous failure.

No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
y problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-script:i386:

 libqt4-script:i386 depends on libqt4-dbus (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-dbus:i386 is not configured yet.

dpkg: error processing libqt4-script:i386 (--configure):
 dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of libqt4-script:
 libqt4-script depends on libqt4-dbus (= 4:4.8.1-0ubuntu4.1); however:
  Version of libqt4-dbus on system is 4:4.8.1-0ubuntu4.

dpkg: error processing libqt4-script (--configure):
 dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of libqt4-xmlpatterns:i386:
 libqt4-xmlpatterns:i386 depends on libqt4-network (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-network:i386 is not configured yet.

dpkg: error processing libqt4-xmlpatterns:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-xmlpatternNo apport report written because MaxReports is reached already

No apport report written because MaxReports is reached already
                            s:
 libqt4-xmlpatterns depends on libqt4-network (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-network is not configured yet.

dpkg: error processing libqt4-xmlpatterns (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-declarative:i386:
 libqt4-declarative:i386 depends on libqt4-network (= 4:4.8.1-0ubuntu4.1); however:

  Package libqt4-network:i386 is not configured yet.
 libqt4-declarative:i386 depends on libqt4-script (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-script:i386 is not configured yet.
 libqt4-declarative:i386 depends on libqt4-xmlpatterns (= 4:4.8.1-0ubun
tu4.1); however:
  Package libqt4-xmlpatterns:i386 is not configured yet.
dpkg: error processing libqt4-declarative:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-declarative:
 libqt4-declarative depends on libqt4-network (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-network is No apport report written because MaxReports is reached already
       not configured yet.
 libqt4-declarative depends on libqt4-script (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-script is not configured yet.

 libqt4-declarative depends on libqt4-xmlpatterns (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-xmlpatterns is not configured yet.

dpkg: error processing libqt4-declarative (--configure):
 dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of libqt4-designer:
 libqt4-designer depends on libqt4-script (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-script is not configured yet.

dpkg: error processing libqt4-designer (--configure):
 dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of libqt4-designer:i386:
 libqt4-designer:i386 depends on libqt4-script (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-script:i386 is not configured yet.
dpkg: error processing libqt4-designer:i386 (--configure):

 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-help:
 libqt4-help depends on libqt4-network (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-network is not configured yet.

dpkg: error processing libqt4-help (--configure):
 dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of libqt4-qt3support:i386:
 libqt4-qt3support:i386 depends on libqt4-designer (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-designer:i386 is not configured yet.

 libqt4-qt3support:i386 depends on libqt4-network (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-network:i386 is not configured yet.
dpkg: error processing libqt4-qt3support:i386 (--configure):
 dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of libqt4-scripttools:
 libqt4-scripttools depends on libqt4-script (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-script is not configured yet.
dpkg: error processing libqt4-scripttools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-scripttools:i386:

 libqt4-scripttools:i386 depends on libqt4-script (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-script:i386 is not configured yet.

dpkg: error processing libqt4-scripttools:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqtgui4:i386:
 libqtgui4:i386 depends on libqt4-declarative (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-declarative:i386 is not configured yet.

dpkg: error processing libqtgui4:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqtgui4:
 libqtgui4 depends on libqt4-declarative (= 4:4.8.1-0ubuntu4.1); however:
  Package libqt4-declarative is not configured yet.

dpkg: error processing libqtgui4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl:

No apport report written because MaxReports is reached already

 libqt4-opengl depends on libqtgui4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtgui4 is not configured yet.

dpkg: error processing libqt4-opengl (--configure):
 dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of libqt4-opengl:i386:No apport report written because MaxReports is reached already

 libqt4-opengl:i386 depends on libqtgui4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqt4-opengl:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-svg:
 libqt4-svg depends on libqtgui4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtgui4 is not configured yet.
dpkg: error processing libqt4-svg (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-svg:i386:No apport report written because MaxReports is reached already

 libqt4-svg:i386 depends on libqtgui4 (= 4:4.8.1-0ubuntu4.1); however:
  Package libqtgui4:i386 is not configured yet.
dpkg: error processing libqt4-svg:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libqt4-dbus
 qdbus
 libqt4-dbus:i386
 libqt4-network:i386
 libqt4-network
 libqt4-script:i386
 libqt4-script
 libqt4-xmlpatterns:i386
 libqt4-xmlpatterns
 libqt4-declarative:i386
 libqt4-declarative
 libqt4-designer
 libqt4-designer:i386
 libqt4-help
 libqt4-qt3support:i386
 libqt4-scripttools
 libqt4-scripttools:i386
 libqtgui4:i386
 libqtgui4
 libqt4-opengl
 libqt4-opengl:i386
 libqt4-svg
 libqt4-svg:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

Running sudo dpkg --configure -a produces very similar results. Does anyone know how I can resolve these errors? I am currently unable to install any packages.

share|improve this question
up vote 1 down vote accepted

I was able to fix this problem by removing the ubuntu-desktop package as well as unity-2d and all of the qt packages. Then, I reinstalled everything. Now, I can install packages without any trouble.

share|improve this answer
1  
in the future aptitude might give you a solutoon not provided via apt-get / dpkg – virtualxtc Jan 15 '14 at 8:08

I had a similar problem. I had to remove many QT packages, purge them, then do a dist-upgrade:

dpkg -r --force-all \
 indicator-appmenu \
 libdconf-dbus-1-0 \
 libdconf-qt0 \
 libqt4-dbus \
 libqt4-declarative \
 libqt4-declarative-folderlistmodel \
 libqt4-declarative-gestures \
 libqt4-declarative-particles \
 libqt4-declarative-shaders \
 libqt4-designer \
 libqt4-dev \
 libqt4-opengl-dev \
 libqt4-script \
 libqt4-scripttools \
 libqtbamf1 \
 libqtcore4 \
 libqtdee2 \
 libqtgconf1 \
 libqtgui4 \
 libunity-2d-private0 \
 qt4-dev-tools \
 qt4-doc \
 qt4-qmlviewer \
 qt4-qtconfig \
 ubuntu-desktop \
 unity-2d \
 unity-2d-panel \
 unity-2d-shell \
 unity-2d-spread \
 unixodbc-dev

dpkg --purge \
 indicator-appmenu \
 libdconf-dbus-1-0 \
 libdconf-qt0 \
 libqt4-dbus \
 libqt4-declarative \
 libqt4-declarative-folderlistmodel \
 libqt4-declarative-gestures \
 libqt4-declarative-particles \
 libqt4-declarative-shaders \
 libqt4-designer \
 libqt4-dev \
 libqt4-opengl-dev \
 libqt4-script \
 libqt4-scripttools \
 libqtbamf1 \
 libqtcore4 \
 libqtdee2 \
 libqtgconf1 \
 libqtgui4 \
 libunity-2d-private0 \
 qt4-dev-tools \
 qt4-doc \
 qt4-qmlviewer \
 qt4-qtconfig \
 ubuntu-desktop \
 unity-2d \
 unity-2d-panel \
 unity-2d-shell \
 unity-2d-spread \
 unixodbc-dev

apt-get -f dist-upgrade
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.