Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to set some custom colors on the user@hostname:~$ on the terminal. I edited both ~/.bashrc and /etc/bash.bashrc

Where it said:

debian_chroot:+($debian_chroot...

I just changed it to:

debian_chroot:::::::+($debian_chroot

To see if the changes had any effect, but it rebooted and the terminal still looks like the default.

What am I doing wrong? I am using Ubuntu 12.04

share|improve this question
    
If that's what it looks like, you changed the middle of an unrelated variable expansion in a way that won't do anything visible to normal accounts. Do you normally change random stuff in random ways in your dotfiles, ignoring the possibility that the wrong random thing might leave you unable to log in or unable to open a terminal? –  geekosaur May 4 '12 at 23:41
add comment

1 Answer

up vote 2 down vote accepted

First:
Pay attention that after the line if [ "$color_prompt" = yes ]; then there is to options, one if the line force_color_prompt=yes is commented and the other if it isn't. Make sure to change the right one.

Then:
You are changing the wrong place at the line. The complete line would be something like:
PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '.

So the change you mean is something like:
PS1='${debian_chroot:+($debian_chroot)}\u@\h:::::::\w\$ '

(NOT: PS1='${debian_chroot::::+($debian_chroot)}\u@\h:\w\$ ')

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.