Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 12.04 inside VMWare Workstation.

What is wrong with my installation so that I cannot resize the window at the lower right corner? The lower left does work, albeit it's really hard to get it; upper left/right works OK, see this video:

http://www.youtube.com/watch?v=mMNItB0BN-8

Just to make it clear: this is not restricted to terminal, same with Firefox, synaptic, etc.

share|improve this question
    
Another reason not to upgrade to 12.04, though I've got to admit, the one that really takes the cake is askubuntu.com/questions/128249/… –  BullfrogBlues May 29 '12 at 21:36
add comment

7 Answers

up vote 12 down vote accepted

I have exactly the same issue, also running Ubuntu 12.04 in a VMware virtual machine. It's the same using VMware Fusion and VMware ESXi. It is also extremely difficult to grab any window edge, for example, to stretch the window horizontally or vertically.

The only solution I have found so far is to use the shortcut of holding down ALT and using the third button (usually middle) on the mouse if you have one. This will allow the window to be resized while the pointer is within that window's boundary, bypassing the need to grab the lower-right corner.

share|improve this answer
1  
lol, hilarious. Never heard about this way, absolutely useful because you don't need to grab anything small or so. Thanks a lot. –  mark May 29 '12 at 21:54
add comment

My problem was that the resize action was disabled in my compiz configuration. I solved it using Unable to resize windows

share|improve this answer
    
For me, when opening the CCSM, the setting was actually checked, but I unchecked it, and then checked it again, and voila!, it works. Stupid stuff. –  stolsvik Apr 16 '13 at 11:44
add comment

I am using Ubuntu on an ACER netbook, and Alt+F8 or right clicking the title bar weren't working for me. I didn't have a third mouse button but was able to shift the window up by using Alt+ double tap on my touch pad.

share|improve this answer
add comment

I have found a few methods to solve this.

First, right clicking the title bar gives you a menu with re-size in it. Then whichever corner your pointer is closest to becomes a re-size handle which you then left click to end. This method only lets you be closest to the upper left and right corners however.

So... if you instead, use alt and a right click in the window, again you get a menu, but this way you can begin in the lower left or lower right of the window and then whichever you were closest to becomes the re-size handle. Then you re-size until satisfied, and then left click to release and keep the new size.

And lastly, since this menu show that alt-F8 is a shortcut, place the mouse pointer in the window closest to the corner you wish to re-size from and type alt-F8. When you release the keys, the mouse pointer will attach to the corner and you can re-size. Again, left click to end.

share|improve this answer
add comment

There is a bug report for the fact that on Unity 2D (which I think is being run in the video, and may be the only option in VMWare) the borders are very thin and difficult to grab, though why you should see this particularly on that corner I don't know.

https://bugs.launchpad.net/ubuntu/+source/metacity/+bug/878198

There is a workaround in comment #8. It may be that will fix the problem here.

share|improve this answer
add comment

I have the same problem on default setup (just installed gnome-session-fallback) under VMware Player with Windows host OS.

The alt+middle click trick works. You can also resize on upper-left window corner.

share|improve this answer
add comment

If you have been tweaking around with Compiz, this could have caused the problem. If not, login in with gnome classic, and see if it still has the same problem.

share|improve this answer
    
I don't remember any tweaking; I also tested this with the guest account which I never used before, i.e. clean home directory with no old preferences. –  mark May 5 '12 at 21:53
    
Did you try to log in with Gnome Classic? –  Nico Bellic May 5 '12 at 22:07
    
how? On the login screen I can only choose "Ubuntu" and "Ubuntu 2D" (tried both) –  mark May 5 '12 at 22:11
    
This is an extremely strange bug. Updating your distro (Press Alt-F2 and type update-manager -d) might help. If it doesn't, any thoughts on re-installing ubuntu? I know it sounds like a pain, but a clean 12.04 installation will very likely help. –  Nico Bellic May 5 '12 at 22:18
    
thanks for the help so far. I'm running inside VMWare and I get the impression that it is maybe due this. I've also asked another question asked which hints me in the same problematic origin: askubuntu.com/questions/132348/… . –  mark May 5 '12 at 22:42
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.