Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently upgraded to 12.04 and the application lens is intermittently appearing in the dash. When it doesn't appear any programs don't appear when searching for them. However the icon for the application lens still appears. I have tried reinstalling it to no effect. It only reappears when you run unity --reset.

Unity Dash As you can see the application lens icon appears, but doesn't appear in the list. How can I fix this?

share|improve this question
add comment

1 Answer

How did you do the upgrade? If it was from the update manager, this suggests that there was an underlying problem in your previous installation - very likely gnome related and this has now caused what you are getting.

You could try doing : sudo apt-get install ubuntu-desktop^

Don't forget the caret ....

And if you haven't already tried, some or all of these might help. sudo apt-get clean sudo apt-get autoremove sudo apt-get update sudo apt-get upgrade sudo apt-get -f install sudo apt-get install ubuntu-desktop

share|improve this answer
    
None of these commands worked, but thanks for the help! –  Dandyman May 5 '12 at 19:08
    
Sounds like a really faulty upgrade. Make certain you have all your stuff backed up while the system is still live - you may need to re-install. –  barrydrake May 5 '12 at 23:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.