Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 while it was in beta2 stage. Since then I have been receiving regular as well as partial upgrade (I don't understand why I am provided this option though I am on the latest Ubuntu release) options. I was never able to play formats like MP4 using native 'Movie Player'. Every time I tried playing such formats, movie player used to search for plugins and finally used to give me this result: The following packages have unmet dependencies:

gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                      Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                      Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                      Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                      Depends: libglib2.0-0 (>= 2.31.2) but 2.32.1-0ubuntu2 is to be installed
                      Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1 is to be installed
                      Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                      Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                      Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                      Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
gstreamer0.10-ffmpeg:i386: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                           Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                           Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                           Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                           Depends: libglib2.0-0 (>= 2.31.2) but 2.32.1-0ubuntu2 is to be installed
                           Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1 is to be installed
                           Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                           Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                           Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed
                           Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.1ubuntu1 is to be installed

Today after I did a 'partial upgrade' my VLC media player went missing. It was probably uninstalled during the partial upgrade process. Since then when I try installing VLC I get this error:

 vlc : Depends: vlc-nox (= 2.0.1+git20120502+r198-0~r36~precise1) but it is not going to be installed
       Depends: libvlccore5 (>= 2.0.0) but it is not going to be installed
       Recommends: vlc-plugin-notify (= 2.0.1+git20120502+r198-0~r36~precise1) but it is not going to be installed
       Recommends: vlc-plugin-pulse (= 2.0.1+git20120502+r198-0~r36~precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I use ppa:videolan/stable-daily PPA.

How do I solve this issue?

share|improve this question
    
Try "sudo apt-get install -f" –  harisibrahimkv May 4 '12 at 18:40
1  
How about "dpkg --configure -a"? –  harisibrahimkv May 4 '12 at 18:41
    
First one worked.. I forgot to include vlc in the command.. –  Chethan S. May 4 '12 at 18:42
    
So everything is cool now? –  harisibrahimkv May 4 '12 at 18:43
    
Seems like that.. Downloading and installing is on.. –  Chethan S. May 4 '12 at 18:44
add comment

1 Answer

up vote 1 down vote accepted

The reason you are given partial upgrade options is because you are using the third party PPA and it is introducing dependency issues that cannot be satisfied.

You have a few options.

  1. Remove the videolan/stable-daily PPA and install VLC from the official repos
  2. Contact the owner of that PPA and ask them why they are depending on the git20120502 version when their PPA contains the git20120503 version (you might also try installing VLC again since it may have been a packaging issue that has been resolved)
  3. Find the correct version of vlc-nox and libvlccore5 and install them manually via dpkg.
share|improve this answer
    
+1 for helping me understand why I get partial upgrade options again and again. –  Chethan S. May 4 '12 at 18:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.