Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded version 11.04 and it does not find the drivers to install and can not even find anything on google to fix this problem. thought I was my wireless did not work on linux, but I downloaded the Ubuntu version ultimate gamers, and my wireless worked normal I downloaded version 12.04, thinking it would fix q hitch, but then nothing = / Please give me a light. I can not stand to use another OS, I want Ubuntu!!!

share|improve this question
    
Er.. What is your problem actually? Wireless not working on 12.04? –  harisibrahimkv May 4 '12 at 18:22
    
My wireless does not work in unity with ubuntu, but ubuntu gamers already in the works normal when I'm in the live cd 12.04 message appears in network connections: wireless hardware disabled. and this has already happened in version 11.04, I waited to see if the update would fix this problem and nothing ... –  Davi Sá May 4 '12 at 18:28
2  
We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro Jun 23 '12 at 17:38
add comment

5 Answers

Which wireless card are you using?

Reply with the output from the following command: lspci

share|improve this answer
add comment

If it's a broadcom wireless card then you will need to run the following to get wireless working.

sudo apt-get install firmware-b43-installer
share|improve this answer
add comment

I had a similar problem. In my case, it was working fine, but I had to reinstall Kubuntu (unrelated issue), and it wasn't working anymore. I fixed it like this (requires wired connection):

Go to System >> Additional Drivers.
Remove the Broadcom STA drivers.
Activate Broadcom STA drivers (will download and reinstall).
Problem solved.

share|improve this answer
add comment

Things helped me to enable wireless network:

My laptop: Vista, Compaq, UBUNTU 12.04

  1. lshw returned *-network UNCLAIMED
  2. connected to wired network
  3. ran sudo apt-get update;
  4. Verified broadcom driver in "Additional Drivers". Wirless options are not yet available after this step.
  5. lshw returned *-network DISABLED.
  6. ran sudo modprobe b43; At this point I was able to see the wireless options in the menu, but these options are not enabled. The light on wireless switch is amber.
  7. ran echo b43 | sudo tee -a /etc/modules > /dev/null; still not wireless is not enabled. The light on wireless switch is amber.
  8. ran sudo apt-get install firmware-b43-installer; This turns the wireless light to blue and wireless options are available.

I have read many blogs. Each step here comes from a different blog. But finally worked. Thanks for everyone.

I am still wondering how did the wireless worked automatically when I ran Ubuntu from CD in recovery mode and why can't the install do the same! That would save a lot of time.

share|improve this answer
add comment

Connect to the internet on that computer with ethernet if possible and go to PREFERENCES >> ADDITIONAL DRIVERS

The driver for your wireless card should pop up if you are connected to the internet. Then just click INSTALL or ENABLE.(I forget what verbiage is used there)

share|improve this answer
    
in version 11.04 I also did this, but I will not install the driver from the broadcom wirelss card, so I'll try to get home and put the answer. thank you –  Davi Sá May 4 '12 at 18:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.