Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP notebook with 2hard drives, /dev/hda & /dev/hdb. I have /home on hda and / on hdb. When I installed 12.04 I reformatted hdb which has the root and swap partitions and left the drive with /home untouched. Now when I try to boot I get the following: error: no such device: 8796ed20-2210-4f37-aa38-9b80c883b77a. grub rescue>

I have tried Rescatux and followed a coupleof threads to try and effect a repair to no avail. Any sggestions would be greatly appreciared

share|improve this question

2 Answers 2

I do a grub-install and let it discover the locations on it's own. More info here: http://www.gnu.org/software/grub/manual/html_node/Installing-GRUB-using-grub_002dinstall.html

but harisibrahimkv has a good way too. More than one way to skin a cat.

share|improve this answer
    
Would grub-install automatically figure out the UUIDs? I don't think so because I had this problem with a swap partition and grub-install did not do the trick. I had to manually edit the /etc/fstab file. –  harisibrahimkv May 4 '12 at 18:26
    
yes because if forces you to specify the drive you would like to install it on and the scripts will extract the UUID from that drive. –  Frank Barcenas May 4 '12 at 18:33
    
Cool. :) I wonder why it did not work for me back then then. –  harisibrahimkv May 4 '12 at 18:33
    
Frank, I tried to reinstall grub from the live-cd but upon reboot I get the same error message as above. –  Robb May 4 '12 at 20:24
    
have you tried switching sata cables or startup priority in the bios? Before you did the grub-install? You can try it know and see if it makes a difference. –  Frank Barcenas May 4 '12 at 22:20

Try running "sudo blkid /dev/hda" and "sudo blkid /dev/hdb" and get both of their UUIDS. Refer to this link http://sosaysharis.wordpress.com/2011/07/31/disk-drive-with-uuid-not-yet-ready-or-present-hibernation-option-missing/

After getting the UUIDS, see if those are the same ones in the /etc/fstab file. If not, change them and your boot should work properly.

share|improve this answer
    
Harisibrahimkv, using blkid I found that the UUID for both drives were the same as reported in fstab. I did notice that the grub.cfg file had the same UUID as I noted in the error message above. If I changed the grub.cfg file to use the same UUID as my /dev/hdb do you think that would cure the problem ? –  Robb May 4 '12 at 20:32
    
They say you shouldn't tamper with with grub.cfg file manually because it is generated. But since your system is screwed, I don't think it will hurt trying to tweak it. Go ahead. :) –  harisibrahimkv May 5 '12 at 0:52
    
I just rechecked and I noticed that the UUID numbers that I got from using "blkid" from the live-cd are the same ones used in /etc/fstab and the one used in /boot/grub/grub.cfg. But When I reboot I still get the error message saying "no such device: 8796ed20-2210-4f37-aa38-9b80c883b77a." Do you know of any other location that would have device UUID numbers that could be getting into the boot process ? –  Robb May 5 '12 at 17:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.