Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just updated my macbook to 12.04 LTS and upon install my wi-fi wasn't working or even showing up for that matter. I then downgraded to 11.10 via booting from an install disc. Upon downgrading to 11.10 I had the wifi problem yet again, along with my mouse not working. ( a USB one helped me )

I then restarted the system and wifi and the mouse problems were temporarily fixed. I then installed a few sources & apple drivers via terminal. I rebooted so these could take effect and my computer now won't respond to mouse or even keyboard actions. Even when plugging in a USB mouse or keyboard nothing works.

I can't boot from CD holding C at startup, and can't get into the boot options with shift either. I also have tried Control Alt F1 with no luck.

Any feedback would be greatly appreciated.


share|improve this question

I had the same problem when booting from CD. Then I got it solved by holding the "option/alt" key and it shows whether to boot from CD. Hope it helps. CD was showing up as windows cd for me eventhough it was Linux Mint CD.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.