Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed 12.04 and I have the nvidia card - Geforce 7025/NVIDIA nforce630a. When I install the drivers (295.40), my ubuntu becomes unuseful just like many other user have reported: the Unity/X desktop screen is frozen/unresponsive/black (though the mouse pointer moves fine, and occasionally with luck something responds after a minute or so). I tried to install (with a lot of effort cause I'm new on linux world) the previous version (295.33) and it has worked, but really slow (for example when I open the HUD).

How could I configure my Nvidia card to get better results? Is there any other possibility instead of 295.33??

This is driving me crazy... Thanks in advance.

share|improve this question

closed as off-topic by Seth, Warren Hill, Avinash Raj, Lucio, BuZZ-dEE Dec 15 '13 at 21:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Seth, Warren Hill, Avinash Raj, Lucio, BuZZ-dEE
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Definitely try re-installing your drivers --> Search for drivers in the HUD by pressing the super key. –  surgemcgee May 2 '12 at 16:15
    
What video card do you have? Adding /var/log/Xorg.0.log would be helpful. –  Lekensteyn May 2 '12 at 16:17
    
bug in nvidia drivers bugs.launchpad.net/debian/+source/nvidia-graphics-drivers/+bug/… –  Braiam Dec 13 '13 at 23:00

4 Answers 4

NOTE:

SRU Request:

Please accept nvidia-graphics-drivers-updates in precise-proposed. Driver 295.49 should fix both the problem reported in this bug report and the other one reported in bug #982485 https://bugs.launchpad.net/debian/+source/nvidia-graphics-drivers/+bug/982710

This will hopefully be resolved in the near future so manual driver installs are not necessary.

There is a known bug with several Nvidia cards.

We have been made aware of an interaction problem between the fix contained in the newest release any any card with a chip older than G80, inclusive. This includes the full GeForce 6 and 7 series as well as GeForce 8800GTX and first-gen 8800GTS. We are actively working on resolving this issue and will provide an update as soon as possible.

The symptoms can include graphical corruption, performance issues, crashes and temporary hangs.

The release should be perfectly safe to use with more recent cards than that; I'll update this thread ASAP.

Thanks, - Pierre-Loup

http://www.nvnews.net/vbulletin/showthread.php?t=178460&page=3

The newly-released 302.07 beta driver should include a fix for all the issues I mentioned above. Please open a new thread should you notice an issue with that driver.

http://www.nvidia.com/object/linux-display-amd64-302.07-driver.html

share|improve this answer
    
Upgrading to the 302.07 driver did not fix it :( –  Amith KK May 3 '12 at 5:07
    
I was using 295.20 before with my 8800 -- not sure, but you could try that version. –  cprofitt May 3 '12 at 14:05
    
I've installed the .deb packages from the quantal repository. nvidia-settings and nvidia-sli however shows me that i'm using the 295.40 Driver –  Amith KK May 5 '12 at 3:33

I also have a Geforce 7025 nvidia onboard card - and it has been pestering me since 11.04

What did the trick in 12.04 was installing the latest driver and, for some reason I ignore, lowering the shared memory for the graphic card in the BIOS from 256 to 128. The nvidia drivers work wonderfully now.

To update the drivers with x-swat ppa and to install Nvidia card latest drivers, open Terminal and copy the following commands in the terminal:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

When the installation is complete restart your PC.

When rebooting enter BIOS. Go to Advanced in CPU Settings lower the shared memory from 256 to 128.

This has helped me. I hope it helps you as well. Thank You.

share|improve this answer

NOTE:

SRU Request:

Please accept nvidia-graphics-drivers-updates in precise-proposed. Driver 295.49 should fix both the problem reported in this bug report and the other one reported in bug #982485 https://bugs.launchpad.net/debian/+source/nvidia-graphics-drivers/+bug/982710

This will hopefully be resolved in the near future so manual driver installs are not necessary.

You can manually download and install the 295.20 driver from Nvidia or test the new 302.xx driver they put out.

32bit: http://www.geforce.com/drivers/results/41580

64bit: http://www.geforce.com/drivers/results/41581

You will need to drop to a terminal session to install...

ctrl+alt+F1

Then:

sudo service lightdm stop

Then follow the directions for installing the nvidia drivers.

http://us.download.nvidia.com/XFree86/Linux-x86_64/295.20/README/index.html

share|improve this answer
    
Thanks for your answers. I tried first 295.20 and now I'm using 295.49. Both worked without errors, but the thing is that they are running really slow, for example when I use the HUD or when I watch a video on youtube... and 3D is not working good in a game (assault cube for ex, is unuseful) I can't find any option (with the "NVIDIA X-server setting") to make it run better... any ideas? –  Mati May 4 '12 at 19:31
    
The 295.20 driver worked for my 8800 GTS, so I did not have to do any other tweaks. I am not sure what else to try at this point. –  cprofitt May 5 '12 at 3:25
    
thanks very much, 304.xx works well –  pylover Dec 31 '12 at 8:39

i know what i did wrong now!!! During the installation of the NVIDIA driver, this time i installed 295.49, 1 of the things they tell you to do is disable the NOUVEAU driver by creating a file /etc/modprobe.d/NVIDIA ....conf (can't remember the name), it's on my other PC.

Being a real NOOB, i thot this was something important. So when the installation was over, i moved it away & rebooted. lo & behold, 640x480 resolution! I moved the file back to /etc/modprobe.d, rebooted, & voila!!! it worked!

So i did some research on what exactly does Nouveau do. Here's watt i found out; https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

You have NVIDIA (proprietary - ubuntu-land ppl call it "closed source") or Nouveau - open source driver. In the words of the article; "This driver lacks support for 3D acceleration and may not work with the very latest video cards or technologies from NVIDIA."

Here's an older article describing what the Nouveau project http://www.omgubuntu.co.uk/2011/03/nouveau-open-source-3d-graphics-drivers-for-nvidia-in-ubuntu/

I don't know if this is out of context, but this is what it says; "Whilst they don’t (yet) provide anywhere near the same level of performance as the proprietary drivers most folks use they are a free and capable drop-in."

In summary, use either proprietary or Nouveau, not both!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.