Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed Ubuntu Server 10.04 on an old laptop and I noticed that the system is trying to show the CLI below my screen. This means that if I run a script or a program with a bunch of output, once it is done, I have to press return several times to bring the output to the point where I can actually see it on the screen. I also have to clear the screen to be able to see what I am typing at the current command prompt.

The laptop is an EliteGroup 536S with a native screen resolution of 1024 x 768

How can I adjust the resolution for Ubuntu Server 10.04?

What file do I need to edit if editing a file is the solution?

I've seen posts on how to change the resolution on the desktop version of Ubuntu but not the server version.

share|improve this question
    
Please add your laptop model and its native resolution. –  tinhed Nov 14 '10 at 13:11
    
Are you also logged in through ssh, and using screen or byobu? –  JanC Nov 14 '10 at 17:40
    
@JanC I'm just running it on the laptop looking at the laptops screen. –  Mike Grace Nov 14 '10 at 17:46

2 Answers 2

You can add kernel parameter vga=792 or so (depends on your monitor)

  VGA Resolution Codes for GRUB & Lilo
--- Depth --
Colors  bits  640x480  800×600  1024×768  1152×864 1280×1024  1600×1200
   256    8   vga=769  vga=771   vga=773   vga=353   vga=775    vga=796
 32000    ?   vga=784  vga=787   vga=790   vga= ?    vga=793    vga= ? 
 65000   16   vga=785  vga=788   vga=791   vga=355   vga=794    vga=798
 16.7M   24   vga=786  vga=789   vga=792   vga=795   vga=799
share|improve this answer
    
That looks like what I am looking for. How do I edit this 'kernel parameter'? (location) –  Mike Grace Nov 16 '10 at 4:27
1  
While in GRUB menu, press "e", edit kernel line and press Ctrl-X. If you want make it permanent, edit /etc/default/grub and run sudo update-grub. –  Extender Nov 16 '10 at 5:12
    
Thanks! I'll try that. –  Mike Grace Nov 16 '10 at 6:20
    
I tried that, but it only changes the screen resolution while grub is running. It does not change it once booting is done. I'm running Ubuntu 10.04 Server. How do I change the screen resolution so it applies at all times ? I'm running an Intel mini-ITX motherboard with built-in display adapter. It has a default resolution of 1920 x 1080 that matches my LCD, and that's the resolution I get once grub is done. I usually operate the server headless, so I don't know what resolution I get without a monitor connected. How do I determine that via remote login ? –  NewtownGuy Mar 3 '11 at 15:56

Both vga=xxx or Elric's link to benhaines.co.uk solution didn't work in my Virtualbox Ubuntu Server.

What works for me was found at:

http://ubuntuforums.org/showthread.php?t=1743535

I added "nomodeset vga=792" to grub. Change the 792 to a number suitable for your screen size.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.