Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I did a:

sudo dpkg -i --force-depends package.deb

The program was confused about a package that wasn't installed (it was). The program works fine, however now whenever I do an update, i get this message:

You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 fern-wifi-cracker : Depends: aircrack-ng (>= 1.0) but it is not installable
E: Unmet dependencies. Try using -f.

The software center, update manager, everything is giving me hell. The question is, how do I tell the computer that everything is ok, and there are no unmet dependences?

if i do:

sudo apt-get install -f

it wants to remove the program I have installed (not a good option if you ask me).

Any ideas on how to get my computer to chill out?

EDIT: Added what actually happens with last command:

user@computer:~$ sudo apt-get install -f
[sudo] password for user: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 32 not upgraded.
    After this operation, 1,532 kB disk space will be freed.
Do you want to continue [Y/n]? 
share|improve this question
sudo apt-get install -f fixes the dependency problems and lets your computer "Chill out". :) – harisibrahimkv May 4 '12 at 13:40
When I do sudo apt-get install -f, it wants to remove the program that I installed. That's not acceptable. I mentioned that in my post. – triunenature May 4 '12 at 13:46
up vote 0 down vote accepted


you have to remove that package by pressing 'y' because it did'nt installed completely .for the further installation process remove it

Advice:- Dont use dpkg -i to install deb files ,Instead of that you can use gdebi ,it is safe and have gui frontend

share|improve this answer

The only way to fix this is to remove the package, by typing sudo apt-get remove package (replace "package" with the neame of the package with unmet dependencies). I dealt with this problem for a long time with codeblocks (a C++ IDE). Tried everything and believe me, this is the simplest and best solution. Hope it helps.

share|improve this answer

Install a deb that says it provides aircrack-ng.

It appears it used to be in universe, but hasn't been bumped for precise. I just ran a test build only bumping the distribution and it seems to work.

I upped the package to PPA. It should be available here pretty soon, if I didn't mess anything up.

You may want to tack a bug on the universe package page asking for a version bump.

share|improve this answer
Thanks for adding the package. :D – triunenature May 5 '12 at 4:23
an upvote might have been nice – RobotHumans May 5 '12 at 4:29
triunenature only has 3 rep points and so can't upvote yet. – Chan-Ho Suh May 5 '12 at 6:12
apt-get autoremove linux-image-generic-pae linux-generic-pae

This command worked for me! Got rid of that unmet dep's error as well as cleaning up my /boot partition.

share|improve this answer
Why removing those packages? – Braiam Sep 3 '13 at 16:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.