Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The following error shows every time I sign into Gmail. On the contrary, I can open Gmail in Windows.

The connection has timed out The server at www.google.com is taking too long to respond.

  1. The site could be temporarily unavailable or too busy. Try again in a few moments.

  2. If you are unable to load any pages, check your computer's network connection.

  3. If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Please help.

share|improve this question
    
@dhanam: Could you please give some details about your internet connection - wired/wireless, direct/requires password, static/dynamic ip, etc? –  Mussnoon Nov 14 '10 at 6:22
    
Maybe google is banned in your country (China)? –  Extender Nov 14 '10 at 7:52
add comment

6 Answers 6

Open a terminal and type: ping google.com

You should get something like this.

64 bytes from iy-in-f105.1e100.net (209.85.225.105): icmp_req=3 ttl=50 time=34.0 ms`

Do a control C to stop the continuous output If just sits their with no output

  • your not hooked to the internet
  • or Name resolution is not working.

To check the name resolution part ping google's IP address: ping 209.85.225.105

Expected output:

PING 209.85.225.105 (209.85.225.105) 56(84) bytes of data.
64 bytes from 209.85.225.105: icmp_req=1 ttl=50 time=35.1 ms

Do a control C to stop the continuous output.

  • If it did not work in first step and this does work--DNS problem report back
  • If it did not work in ether your Linux software is NOT hooked up to the Internet.
share|improve this answer
add comment

I was also facing the same issue, even after updating the proxy address. But here is what I did and it started working for me.

  1. Open Mozilla Firefox
  2. Click Edit -> Preferences -> Advanced -> Network -> Settings
  3. Check "Use this proxy server for all protocols"

I already had a proxy address and port, but I did not click on "use this proxy server for all protocols". When I click it and closed the browser, Gmail started working.

share|improve this answer
add comment

Firefox should work well with Gmail from any operating system, however it could be a glitch of Firefox (its configuration) or a faulty firefox plugin.

Try to login to Gmail by mean of Google Chrome (Chromium) or Opera browsers, then check what type of connection you are using (http or https). Google strongly suggest to use an HTTPS. Try to switch to 'http and https' connection settings. I think Firefox should open Gmail by HTTP protocol.

share|improve this answer
add comment

First of all, test if the problem occurs with other browsers.

If the problem occurs with other browsers:

Is possibly a network issue, like DNS resolution. In this case disable ipv6 in grub.

gksudo gedit  /etc/default/grub

Then replace the following line:

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”

With the following line:

GRUB_CMDLINE_LINUX_DEFAULT=”ipv6.disable=1 quiet splash”

Then update grub and reboot:

sudo update-grub

If that doesn't help, try a different DNS server like OpenDNS or Google Public DNS.

If the problem occurs only with Firefox:

Clear your browser cookies and browser cache, then try again. If that doesn't help, disable ipv6 in Firefox preferences.

  1. Type about:config in the address bar, press Enter.
  2. Find network.dns.disableIPv6 in the list.
  3. Right-click -> Toggle.
  4. Restart Firefox and try again.

If that doesn't help, start Firefox in safe mode. Close Firefox, then:

firefox -safe-mode

If that works, then is an extension affecting your login. You can disable all extensions from the safe mode starting dialog and then enable one-by-one until you find the culprit.

If that doesn't help, create a new Firefox profile and test it. You can create a new profile by starting the profile manager. Close Firefox, then:

firefox -P

If that solves the problem, then see the tutorial "Fixing a problematic or corrupted profile". If the problem persist even when using a new profile, then create a new Ubuntu user and test it. You can do that from "System >> Administration >> Users and Groups". If the problem does not persist when using a new user account, then you need to figure out which of your Gnome settings is affecting the Gmail login. Report back with the results.

share|improve this answer
add comment

The problem may also be related to your cookies. This could happen if you have an invalid cookie. Try removing all google/gmail cookies and then try to load the site - http://support.mozilla.com/en-US/kb/Deleting+cookies

share|improve this answer
add comment

He says all other websites are opening so obviously he is connected to the internet. Incorrect DNS is definitely a possibility. Can you try a ping like stevehendo34 says?

share|improve this answer
    
Woops wtf i can't read he could try pinging it for the heck of it anyway –  stevehendo34 Nov 14 '10 at 8:18
    
This was not an answer, please writer under the comment section if its not an answer. –  Gaurav Butola Nov 14 '10 at 17:44
    
not your fault, you need more privileges to be able to write on comment. Until you get enough privilege, keep answering and help marking good answers as useful :-) –  crncosta Nov 14 '10 at 20:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.