Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu Lucid Lynx. I installed it using the feature 'Install within Windows'. I got a simple though difficult problem.

Touch pad and external mouse movements are working fine.

I am able to :

  • Maximize,minimize,close an opened window using the buttons on window.
  • Drag a window by double clicking and holding it.
  • Rise up a context menu with a right click on the window border.
  • Scroll through a page with the Mouse wheel.

I am not able to :

  • Left click or right click on a panel.
  • Open a menu item from the menu bar using click.
  • Open a folder by double clicking it.
  • Rise up a context menu for a right click inside the window area.
  • Click an item in side pane.
  • Scroll through a page dragging the scroll bar.
  • Select OK or cancel in the pop up windows by a click. [To do so, I have to use tab to go the option and press enter].

It happened as follows :

I finished installing the packages planets, sugar-emulator, rlplot, gsynaptics, then opened the package planets, added a planet in the opened window.

*The planets window said to press Ctrl + Shift to release mouse from its window to normal ubuntu environment. I doubt my keystroke was wrong. I am not sure what i pressed. Something wrong went from there. *

I thought a restart would clear the problem, but it didn't. I removed all the installed packages and their dependencies, restarted my laptop. Still, the problem exists.

I am using my laptop with all the keyboard shortcuts i know. And i have to press tab many times to select something and it is really bad.

Solution ?

  1. Should i install any drivers for my touch pad ?
  2. Is there any option to restore my system to an earlier point of time as is possible in windows?
  3. Should i change any settings ?
  4. Can i recovery using any boot up installation?
share|improve this question
Does this happen after a reboot? Does this happen in the guest session or logged in as another user? – Martin Owens -doctormo- Nov 14 '10 at 12:01
@Martin Yes, happened after a reboot too. No, not in a guest session or not logged in as another user. – Vinay Challuru Nov 14 '10 at 13:26
up vote 4 down vote accepted

Your gnome settings are corrupted some how. Instead of spending time debugging them all, your quickest solution is to create a new user and move over your document files. The other option is to try and reset the options for gnome:

From a terminal which you can get to by going Applications > Accessories > Terminal, copy and paste the following:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

This will remove all of your gnome settings and set them to the default settings. These files are normally hidden files and you don't normally see them in your home folder from nautilus (nautilus is the file manager that is shown when you go to Places > Home).

Log off and back on to apply the changes.

share|improve this answer
@Martin I will consider what you said. – Vinay Challuru Nov 15 '10 at 4:09
@Martin I now created a new user account, say 'user2'. I gave the 'user2' with administrator privileges. I didn't even copy my documents stored under 'user', still I can access them from /home/user/. Anyways, you said to delete settings folder going to nautilus. Can u tell me how i can go to nautilus.? Using root ? Since no problem exists in 'user2' account, i would like to ask u, "Is there a way to reset an user's settings or changing them to default.?" – Vinay Challuru Nov 15 '10 at 11:20
@Vinay - I've updated my instructions. – Martin Owens -doctormo- Nov 15 '10 at 11:47
@Martin I got my doubt cleared. I knew what nautilus is. But, i thought that i should go and edit files in a folder like /root/bin/nautilus/ some kind of them. I now came to know that, these files are hidden in the /home/ folder. My problem is now solved. I thank you very much for your concern. – Vinay Challuru Nov 15 '10 at 12:40
Can you re-title the question for me so others can find it? Something like: "Gnome panel and menu bar can't be clicked" – Martin Owens -doctormo- Nov 15 '10 at 13:55

The solution to the problem was very simple

Click in the menu
Then under "Movement Key"
select the radio button for "super (or "Windows Logo")

I don't know if this is the way it is supposed to be set or if it is backwards now (I never looked at this setting before) but my mouse now works correctly on Ubuntu 10.04

share|improve this answer

At least for the panel, you should try restarting the panel via "gnome-panel --replace" command to see if this temporary solves your problem (until next restart). In Ubuntu 10.04 my Desktop didn't have any problems, but with my Laptop, 80% of times I had to restart the panel at boot time ( there was a bug in gnome ).

If @Martin Owens solution doesn't work you could use KDE for a while ( it will be easier to have a working station to help you find a solution, that what I did in 10.10, where in gnome the mouse could not click anything but in KDE worked ). KDE is instaled from software center as kubuntu package, or in CLI with this command :sudo apt-get install kubuntu-desktop

share|improve this answer
This won't work, gnome-panel --replace will only reload the saved settings, so if a reboot won't solve it, this certainly won't. – Martin Owens -doctormo- Nov 15 '10 at 11:48
@Martin Yes, it didn't. But, the panel just got reloaded with its settings. – Vinay Challuru Nov 15 '10 at 12:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.