Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I install the 10.04 LTS Lucid Lynx kernel on my Ubuntu 12.04 LTS system, sound works fine.

But if I use newest kernel of 12.04, it shows my audio hardware but plays no sound.

I don't want use the old kernel, because I think I cannot use some software, including GNOME 3, with it. Or at least they didn't work when I tested the old kernel, and the screen resolution was low.

I also tried newer kernels but only 2.6.33 worked without any sound problems.

My sound card is a Realtek HD ATI ALC1200 integrated card. My front jack is broken and it detects that something is always plugged in--does this affect my situation?

Do I have to buy a new sound card? That would suck.

share|improve this question
    
Did you upgrade Ubuntu from 10.04, or did you install kernel 3.2.0 in 10.04? –  Takkat May 4 '12 at 11:24
1  
Yes. Jack-sense could be breaking you. Can't you just disconnect the front-panel jack? –  hbdgaf May 4 '12 at 11:41
    
@takkat I had 10.04, but I wiped it away and made a clean install of 12.04. I installed 10.04's kernel in 12.04. –  Kimmo69 May 4 '12 at 15:00
    
@aking1012 This is strange. I unplugged the front panels cable, but still no sound from my system. Any Ideas? –  Kimmo69 May 4 '12 at 17:53
2  
@Kimmo69 Could you add the answer as an answer now that you've solved the problem, rather than including it in the actual question :) –  coversnail May 4 '12 at 21:36

1 Answer 1

The original poster was able to solve the problem as follows (moved from being an edit to the question, to here):

I fixed this problem by going to alsamixer. There was this thing called "automute-mode" and it was enabled. By disabling it, my sound started working again. I think this had something to do with my broken front jack.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.