Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Permissions do not function correctly if I mount a Windows 7 share using

sudo mount -t cifs //Host/share /mnt/share -o username="Windows User",password="password",iocharset=utf8,uid=user,nobrl,noserverino,cifsacl

Specifically, I cannot remove the read or execute bit from a file, but I can change the write bit. All of the files have the write and execute bit set for user, group and other. The execute bit is not set in the Windows permissions.

I have been using this command on an openSUSE install successfully. When mounted on that distro the files reflect the actual Windows permissions and do not all have the execute bit set. Furthermore, I am able to change the permissions using chmod.

(Note, I am running the Linux installs in VMware Workstation 8.0.3).

Kubuntu 12.04 64-Bit:

Linux Hostname 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux.

openSUSE 12.1 64-Bit:

Linux Hostname 3.1.10-1.9-desktop #1 SMP PREEMPT Thu Apr 5 18:48:38 UTC 2012 (4a97ec8) x86_64 x86_64 x86_64 GNU/Linux
share|improve this question
    
I think the kernel option CONFIG_CIFS_ACL is needed but is not set in the default kernel. I am investigation this option now. –  Evan Sosenko May 4 '12 at 18:35
add comment

1 Answer 1

up vote 0 down vote accepted

For proper ACL support, you need to compile a custom kernel with the CONFIG_CIFS_ACL option enabled. As of 12.04 this is not set by default

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.